WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WordPress Portfolio Plugin (WP Portfolio)] WP Table Prefix [WordPress Portfolio Plugin]

[Resolved] [Plugin: WordPress Portfolio Plugin (WP Portfolio)] WP Table Prefix [WordPress Portfolio Plugin]

  • FuturityWeb
    Member

    @futurityweb

    WordPress Portfolio Plugin will not allow me to update Portfolio items. Error pasted below…

    WordPress database error: [Unknown column 'displaylink' in 'field list']
    UPDATE t2tb5pffz_WPPortfolio_websites SET <code>sitename</code> = 'Big Bay Property', <code>siteurl</code> = 'http://www.bigbayproperty.co.za', <code>sitedescription</code> = 'Big Bay Property for Sale, Cape Town South Africa. Buy, Sell or Rent property in Big Bay!', <code>sitegroup</code> = '1', <code>customthumb</code> = '', <code>siteactive</code> = '1', <code>displaylink</code> = 'show_link', <code>siteorder</code> = '0', <code>specificpage</code> = '0', <code>customfield</code> = '', <code>siteadded</code> = '2012-07-05 07:34:10' WHERE <code>siteid</code> = '2'

    The only major change to my website is the addition of the “Better WP Security” which has changed the default WP Table Prefix. Could this be the issue or am I looking in the wrong place?

    http://wordpress.org/extend/plugins/wp-portfolio/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Try activating or deactivating the plugin. That might work.

    Otherwise I’m just preparing a new release now which has a force upgrade tables setting, which should fix that issue. It should be live in a few minutes.

    Kind Regards
    Dan

    Look for the “Upgrade Tables” section in the “Portfolio Settings”. This is live in V1.31 which I have literally just uploaded now.

    Dan

    FuturityWeb
    Member

    @futurityweb

    @dan
    Thanks for the prompt reply. I fixed the issue last night & will advise what I did for others. Initially, I tried deactivating & re-activating the plugin with no luck. So, I deleted the plugin and then immediately re-installed it and it worked (somehow, somewhere, it kept all my settings intact and I assume this was because of the Cache).

    I also have an issue with the HTML not working for the descriptions, so hoping this update will fix it… Will advise!

    Thx again
    Duane

    Hi Dan,

    I try both ways and still doesn’t work, should I drop the database? I don’t understand why the thumbnails can’t show up after plugin update?

    Thanks,
    Clarence.

    Sorry for the confusion, once it’s updated, the file permission has been switched back from 777 to 755. It’s weird. Thanks.

    Hi Clarence –

    this is due to the way WP works when updating plugins. Changing your cache location would work too (to use wp-content) for future updates.

    The next time, if there’s an issue, please create a new thread, then we can keep things on topic and get your issue solved more quickly 🙂

    Dan

    Thank you Dan. I’ll create new thread next time.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: WordPress Portfolio Plugin (WP Portfolio)] WP Table Prefix [WordPress Portfolio Plugin]’ is closed to new replies.