WordPress.org

Forums

WordPress Portfolio Plugin (WP Portfolio)
[resolved] Remove Link To Shrink The Web Style Sheet From H (11 posts)

  1. larryjames
    Member
    Posted 2 years ago #

    Thank you for an excellent plugin, it is working great for me except that I upload and use my own thumbnails. I do not use the Shrink The Web Service.

    There is an unnecessary reference to the Shrink The Web style sheet in my header that I would like to remove, how to I do this please.

    <script type='text/javascript' src='http://www.shrinktheweb.com/scripts/pagepix.js?ver=1340818646'></script>

    http://wordpress.org/extend/plugins/wp-portfolio/

  2. Lisa Libutti
    Member
    Posted 2 years ago #

    My workaround for that same issue was to go into the "Show Advanced Settings" link and upload my own screenshot of the project.

  3. Lisa Libutti
    Member
    Posted 2 years ago #

    Additionally, here's the documentation on it:

    -- For free accounts, your images will link to a verification (intermediate) page (what's a verification page).

    --For paid accounts, such as the basic and plus accounts, the plugin will link directly to the website.

  4. larryjames
    Member
    Posted 2 years ago #

    Thanks for your feedback llibutti.
    I upload my own images also. Jut like you I go to the "Show Advanced Settings" and I paste the link to the thumbnail that I uploaded. I do not use the shrinktheweb thumbnail service, but the link to their stysheet is in my header. I do not need it there, and I would like to remove it.

  5. Dan Harrison
    Member
    Posted 2 years ago #

    Hi Larry

    Sorry for the delay in my reply, I've been poorly with flu.

    I'll think of a suitable way to disable the pagepix script for you. It'll probably be a line of code you add to functions.php. I'll reply once I've added that code and committed it to WordPress.org

    Dan Harrison
    [ Signature moderated. ]

  6. Dan Harrison
    Member
    Posted 2 years ago #

    Hi Larry

    Just done a V1.29 release, which adds a way to disable the pagepix.js on the frontend of the site.

    Just add define('WPPORTFOLIO_NO_PAGEPIX', true); to your functions.php (anywhere you like).

    Dan

  7. larryjames
    Member
    Posted 2 years ago #

    Worked like a charm, thank you Dan.

  8. jvandemerwe
    Member
    Posted 2 years ago #

    The way I got rid of the verify link (with a free account of Shrink the Web):

    - in the file thumbnail.inc.php, go the line that says:

    $imagetag = sprintf('<div class="noshrink"><script type="text/javascript">stw_pagepix("%s", "%s", "%s");
                </script></div>', $url, $stwaccesskeyid, $stwsize);

    replace this with:

    $imagetag = sprintf('<script type="text/javascript">stw_pagepix("%s", "%s", "%s");
                jQuery(\'.stwpvplink\').removeAttr(\'onmousedown\')</script>', $url, $stwaccesskeyid, $stwsize);

    Not very chique, but effective.

  9. Dan Harrison
    Member
    Posted 2 years ago #

    I'm hoping to remove this in the next update anyway :)

    Dan

  10. vintageexplorer
    Member
    Posted 2 years ago #

    DAN -
    I saw your WP profile page and was hoping you could help me with some WP website troubleshooting questions about my website "portfolio" page not showing content, just shows blank page.

    I recently installed a "Themeforest" theme on my WP website, http://www.LNGcreativestudios.com, and just created new custom pages/templates, ex. "About" and "Connect" and "Blog." Now, all these pages are working properly, however the "Portfolio" page won't load, even after I followed one of your posts and installed the WP Portfolio Plugin.

    I've tried the following, none worked:
    - I navigated to my Dashboard-->Pages--->Portfolio and the page only defaults to the "Default Template" and not the "Portfolio" page template.
    - I deleted and re-installed all Portfolio-related plug-ins, thinking this would re-set.

    Hope this question is up your alley. If not, please advise on best direction. Thanks!
    Lauren

  11. Dan Harrison
    Member
    Posted 2 years ago #

    Hi Lauren

    Please create a new thread if this is an issue with WP Portfolio (http://wordpress.org/extend/plugins/wp-portfolio/). It's not good practice to hijack another thread by talking about a different issue.

    If the theme has a portfolio feature, then there might be confusion what's going on.

    For debugging work like this, I do have to charge, and I have slots available in 3 weeks (very busy currently).

    Regards
    Dan

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress Portfolio Plugin (WP Portfolio)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic