Support » Plugin: WordPress Portfolio Plugin (WP Portfolio) » Portfolio Thumbnail Images (Self Hosted) Not Showing Up?

  • Resolved Lisa Libutti


    Hi Dan,

    Is anyone else having issues with their self hosted thumbnails? Or could it be something that happened on my end with the server or updates?

    I believe there was just an update for the plugin and I THINK the update may have broke something? Not sure though.

    My issue: All of a sudden all the Thumbnails I have in my portfolio are not showing up. One day they were working, the next day they are just showing the alternate text. You can see it here on my site:

    Even though I have my complete URL to my own screen shot, the plugin is using this as the image code on all the portfolio items:

    I’m also seeing this new error on the “WP Portfolio Settings” page…not sure what it means?

    open_basedir Restriction Set No
    The PHP ini open_basedir setting can cause problems with fetching thumbnails.

    Hoping you can help!

    Lisa Libutti

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’d still like to hear your response. But I think the issue is with my hosting provider based off this thread below:

    🙁 frustrated.. Lisa

    Hi Lisa

    If the issue only applies to self-hosted images that you’re trying to cache, have you tried caching an image on another website?

    i.e. if the image URL works OK when fetching from another website, then you could put all your files in DropBox, get their public URL, and then use that.

    Kind Regards

    Morning Dan, Thanks for your response.

    Yes I have tried hosting the image on an outside site. That doesn’t work either. Additionally what I’ve noticed is in the backend of WordPress for your plugin on the “Summary of Websites in your Portfolio” page – the Thumbnails are not showing up there either. But when I click on “Custom Thumb: View Image” – The image does pop up. However If I switch back to using “Shrink the Web” it does work – do you know why?

    I spoke to my host and this was their response: “We upgraded several things last week so it’s possible that it has something to do with it. The problem is that I can’t disagree with the website saying that the file isn’t there when it isn’t actually there. If something is supposed to be generating the thumbnails, but isn’t, we’d need to find out what that is and see what error it is getting.”

    I believe he’s not clear as to why ALL portfolio images are now showing this URL – even though that’s not what I have them linked as:

    Dan – is this something that I’d need to “hire” you to help me resolve? If so, let me know how to proceed with you.

    I had this all working fine – and now it’s not working 🙁

    Would you be interested in logging into my site and taking a peek around? Again, I’m happy to pay for your time and hire you since you are the one most familiar with this plugin.

    Hoping to resolve this soon…
    Thanks, Lisa

    Hi Dan,

    My host resolved the issue. Here’s his response:

    “The issue had nothing to do with openbasedir but was related
    to the version of php we were running. I’ve upgraded that, changed a
    whole bunch of stuff to make that upgrade possible, and you look like
    your running again.”

    Sorry for the long winded comments here and I appreciate your responses as always. Thank you for your support!


    Hi Lisa

    Fantastic. Just the host then! Thanks for letting me know.


Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Portfolio Thumbnail Images (Self Hosted) Not Showing Up?’ is closed to new replies.