WordPress.org

Support

Support » Plugins and Hacks » WordPress Popular Posts » [Resolved] [Plugin: WordPress Popular Posts] Version Version 2.3.0 breaks the blog

[Resolved] [Plugin: WordPress Popular Posts] Version Version 2.3.0 breaks the blog

Viewing 15 replies - 1 through 15 (of 108 total)
  • Plugin Author Hector Cabrera

    @hcabrera

    Hi firmdot,

    Can you share a screenshot of that? Does it display any error?

    Jsut a heads up that your most recent auto-update apparently did not automatically apply whatever database model changes it was supposed to. It broke the web site and unfortunately our client had to notify us, which is never good. I fixed it by deactivating then reactivating the plug-in.

    Plugin Author Hector Cabrera

    @hcabrera

    That should do the trick. There are several changes that should apply on plugin reactivation, it’s weird that WordPress didn’t refresh plugin’s settings after the upgrade.

    Ah, that fixed it. Good to know in case that happens again with any other plugins.

    I tryed, but reactivation don´t work. 2.3 still breaks my blog.

    Here is link to screenshot

    Sorry my poor english.

    Plugin Author Hector Cabrera

    @hcabrera

    Just checked your site and I didn’t see anything wrong. Widget is displaying the posts as expected so I’m guessing it’s working alright now?

    I had the same problem. It broke all of my posts upon upgrade and I have 1500+ posts. I had to deactivate the plugin. Here’s the error:

    “WordPress database error: [Unknown column ‘day_no_time’ in ‘field list’]
    INSERT INTO wp_popularpostsdatacache (id, day, day_no_time) VALUES (23315, ‘2012-08-31 14:57:13’, ‘2012-08-31’) ON DUPLICATE KEY UPDATE pageviews = pageviews + 1, day = ‘2012-08-31 14:57:13’, day_no_time = ‘2012-08-31’;”

    Plugin Author Hector Cabrera

    @hcabrera

    Hi rebelguru, please deactivate the plugin and reactivate it again. It should fix the problem in your case.

    Update changes colors, font, etc. in my blog. Before picture is what my blog looks and after is what happens when i updated 2.3
    And plugin stopped to work at all. Hope you get what i mean.

    i have 2.2.1 now reinstalled my site, it´s works well. Site address is http://turpeinen.info/

    Plugin Author Hector Cabrera

    @hcabrera

    That’s quite odd and honestly I have no idea of what might be causing it. Can you please tell me:

    # Which version of WordPress are you running?
    # Version and Name of your current theme
    # Currently active plugins on your site

    UPDATE: Guys, if you are using the widget version go to Widgets > WordPress Popular Posts and change the Custom pot type field from Array to post,pages, then click Save. Let me know if that fixes it.

    I ran into the same problem (INSERT error) after today’s update, using WordPress 3.4.1

    Deactivating and reactivating seems to have resolved this issue for me at this point.

    Plugin Author Hector Cabrera

    @hcabrera

    Yes, the new version of the plugin is introducing a new database table field that should be created after the update progress is done. For some reason, WordPress doesn’t seem to be creating this new field when reactivating the plugin again.

    The workaround for that -until I figure out why the table field isn’t being created at reactivation- is to manually deactivate and reactivate the plugin.

    UPDATE: plugin’s core has been updated again with a minor bugfix regarding the new options available. Since it was only one bug, the plugin version remains at 2.3.0. You can either redownload the plugin again in 30 minutes or simply go to Widgets > WordPress Popular Posts and clic Save to update the settings.

    Vaya cagada con la actualización tío!!!!!!!!!!!! xDDD

    Deactivate & reactivate worked for me. Phew.

    Plugin Author Hector Cabrera

    @hcabrera

    @el Chapuzas: son las cosas que suceden cuando implementas cosas nuevas y no pruebas lo suficiente antes de publicar la actualización 😛 Aún así, se arregla fácil jeje

Viewing 15 replies - 1 through 15 (of 108 total)
  • The topic ‘[Resolved] [Plugin: WordPress Popular Posts] Version Version 2.3.0 breaks the blog’ is closed to new replies.
Skip to toolbar