Support » Plugins and Hacks » [Resolved] [Plugin: WordPress Popular Posts] Template does not work in v2.0

[Resolved] [Plugin: WordPress Popular Posts] Template does not work in v2.0

Viewing 15 replies - 31 through 45 (of 71 total)
  • Hey Ikki, timmos…
    I gave it another look and I think that Timmos is right about the order thing! I didn’t noticed before because coincidentally my most viewed posts are the most commented. I’ve tried views, avg, comments, and in all three the list is the same, ordered by the number of comments.

    Timmoss, about the bullets thing. You might want to check if the some ul styling in the css removes the bullets. This is very likely if you reset the CSS or if the theme you’re using removes all the bullets in the lists in the sidebar. You should try this:
    In the code above, replace wpp_start='<ul>' with this wpp_start='<ul class=\"pop_posts\">'. This will assign the class “pop_posts” to the list. Go to your css file and add:

    ul.pop_posts {list-style-type: disc;

    and see what happens. Alternatively you can add the whole function into a div. Something like:

    <div id="popular_posts">
    <?php if (function_exists("get_mostpopular")) get_mostpopular("range=all&......?>

    and in the css file add:

    #popular_posts ul{list-style-type: disc;

    I hope this helps.

    Truth, if you read this, can you please let us know if your list is sorted by comments or views? Thanks.

    Hey guys,

    Sadly, it is a bug. I’m already working on it, should be releasing a new version within the next hour or so!

    Can you please check the rest of the attributes to check if they work as expected?


    Timmos, what’s your site’s URL? I’d like to check what is being printed by my plugin.

    Hey Ikki, I checked all the attributes except from rating since I don’t use WP-PostRatings.
    You might want to have another look at:
    title_length=n -> the number of characters printed is actually n+3
    Also I couldn’t get to do the pattern to work. The code I used:
    do_pattern=1&pattern_form='{title}: {summary} {stats}' and in the output it was just ignored, getting a simple list formatted as if these atrributes didn’t exist.
    Everything else seems to be working fine.

    Alright, thanks mpiftex! Need to play a little bit more with the excerpt function.

    The order_by thing has been fixed already, it was a minor thing! Will try and fix title_length and do_pattern. Once I’m done with that, I’ll release 2.0.2!! (hopefully this should be the last upgrade for now hehe).

    Just updated to v2.0.2 and the sorting problem has been fixed! The title_length is also fixed but I still can’t figure out the pattern attribute. Maybe it’s just me doing something wrong but since I’m not using it this feature I’m not gonna sweat about it.
    Good job Ikki, thanks for all the support.

    ps. I will switch this post to resolved now.

    You gotta set do_pattern to true (do_pattern=1) and also specify the order of the tags (eg. pattern_form=”{title} {stats}”). However, I might change that since the attribute do_pattern seems to be unnecesary and might confuse some people about its use.

    Thank you for your patience and suggestions!

    What do I do to add thumbnails in the shortcode extension, and how do I size them?

    Thanks a lot,Ikki24.

    Try this:

    [wpp thumbnail_width=15 thumbnail_height=15]

    By setting the width and height of thumbnails, WPP will automatically activate this feature (but only if your current server has what’s required for it to work).

    Hey Ikki

    Thanks for your swift updates. The ordering is now working perfectly on my site.

    I still can’t get the bullet points to show but it’s not the end of the world. I’ll keep checking back here in case anyone figures it out.

    However, my ‘Monthly’ category still says ‘Sorry, No data so far’. I read your post about it creating a new file that would take a while to populate but I’ve had it up for about a week now.

    Is this normal is there something I should do?

    Thanks again for your time,

    Hey timmoss,

    The bullet thingy is probably more a css styling issue not related to my plugin but to your theme. Might stop by your site later today to check it out.

    About the monthly range issue, are you using the shortcode, the widget or the template tag?

    Hey Ikki

    I’m not sure which one of those it’s called by I type the code into the sidebar.php in the WordPress editor. Something like this one…

    <div id="popular_posts">
    <?php if (function_exists("get_mostpopular")) get_mostpopular("range=all&......?>

    Thank you!


    You’re running WordPress Popular Posts v2.0.2, right? I tested that code snippet on my local blog and it worked fine for me.

    This is the code I used on my theme:

    <?php if (function_exists(“get_mostpopular”)) get_mostpopular(“range=monthly”); ?>

    Thanks again Ikki. I am indeed using WPP 2.02 and the latest version of WordPress.

    I tried copying your code and still get ‘Sorry. No data so far’

    If anything comes to mind then let me know otherwise I will just have to live with it for now!

    Thanks for all of your help.


    Mmmm how odd. Have you checked phpmyadmin yet? Is the table “wp_popularpostsdatacache” filled with entries? Have your tried setting “range” to something different like “daily” or “weekly” to see if it works?

    Hi Ikki,

    Using WordPress 2.9.2 and WordPress Popular Posts 2.0.2.

    Checking phpmyadmin, its not writing anything to the table “wp_popularpostsdatacache” or “wp_popularpostsdata”. 0 entries although there has been traffic clicking on articles.

    PHP 5.2.10 installed on the server.

    Any thoughts? Would appreciate any help you can provide!

Viewing 15 replies - 31 through 45 (of 71 total)
  • The topic ‘[Resolved] [Plugin: WordPress Popular Posts] Template does not work in v2.0’ is closed to new replies.