Support » Plugin: WordPress Popular Posts » [Plugin: WordPress Popular Posts] Some (but not all) thumbnails showing

  • Resolved aamorrison



    Great plugin. I’ve just upgraded to version 2.1.4 and some (but not all) of my thumnails are showing. Previously most of them did show and I can’t work out what is different between the posts that are showing thumbnails and those that aren’t.

    Any suggestions?


Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi aamorrison,

    From version 2.1.4, WordPress Popular Posts uses the_post_thumbnail functionality (new to WordPress 3.0) that allows the user to select a thumbnail for each post. I wanted to take advantage of this feature, and offer the users of my plugin the ability to select the exact thumbnail they wanted to use.

    Anyways, here’s a short tutorial that should help you out with this:

    Sorry for the inconvenience!

    Hi Ikki24,

    Thanks for your help, sorry I haven’t been able to figure this out. I went to Apperance, then Editor, Theme Functions, functions.php

    But, I can’t write to this file, it is a 755. I tried to change the permissions via Filezilla but I don’t know what I’m doing and I don’t want to mess it up. I’m using the atahualpa theme, version 3.5.3 if that helps any?

    Don’t worry, here’s what you need to do:

    1. Using Filezilla, go to your theme folder (eg. wp-content/themes/atahualpa) and download to your desktop the file functions.php. You might want to make a copy of this file before editing it so you can roll back all changes in case something goes wrong.
    2. Open it using a text editor such as Windows’ Notepad or Adobe Dreamweaver, paste the code at the begginning of the file and save changes.
    3. Reupload this file to your FTP, replacing the existing functions.php file with the one we just edited.

    Give that a try and let me know what happens, ok?

    P.S.: alternatively, you might want to change the file permissions for functions.php to 777 using Filezilla, edit the file using WordPress and change back the file permissions to 755 once you’re done.

    A little knowledge is a dangerous thing, it didn’t work, because of my stupidity!

    I could download wpcontent/themes/atahualpa/functions but I couldn’t find a functions.php file in the functions folder (does that make sense?) I tried adding the code to a file called bfa.themeoptions but that was clearly wrong as all it did was show the code on the top of the dashboard page so I’ve reverted back to the original bfa.themeoptions file.

    I know my inability to find the functions.php file isn’t your problem! I’ll sleep on it and try again tomorrow. Thanks for your help.

    I tried changing the functions folder to 777 but I couldn’t save to the functions.php file on the dashboard, so I put it back to 755. I’m obviously missing something very basic here!

    Again, don’t worry 🙂 If there’s anything I can do to help, I’ll do it.

    This is the functions.php file you need to edit:

    Please do remember to come back and post the results. And if you need more help, don’t hesitate to ask!

    P.S.: I believe it was Albert Einstein who said: “we are all very ignorant, but not all ignorant of the same things”. Don’t call yourself stupid just because you can’t do something, all you need is a little more patience 😉

    I wrote post about thumbs missing and then found
    “thumbnail_selection=”wppgenerated/usergenerated” switch…write RTFM 1000 times ^_^

    No harm has been done, QAsker ^_^ We’ve all been there at least once. Glad to know that you actually took the time to RTFM! lol!

    Thanks for the screenshot Ikki24, I realised I was looking in the functions folder instead of at the functions file, all I had to do was scroll down a bit (!). Anyway, I’ve added the code and I’ve written a new post and I do have a “Featured Image” button. Thanks.

    I do still have a problem with my old posts though, I’m using Popular Posts in a widget in my right hand side bar (automatically generated). Most of my posts do have images, but some are showing up as a grey box saying No Thumbnail. Do I have to go back through every post and select the image as a featured image do get the thumbnail to show? Why do some of them work but not all?

    Thanks again for your help.

    @aamorrison, haven’t asked you this before: have you set WordPress Popular Posts to generate all thumbnails for you or to use the ones you’ve picked?

    If you set it to “Generate all thumbnails for me” WPP will attempt to find all images attached* to your post, and the use the first one to create a thumbnail from it using timthumb.php (an external script I use with WPP to generate the images). However, if no images are found attached to your post’ content then WPP will use the default “No thumbnail” image (this will happen even if you have selected a featured image for it).

    On the other hand, if you select “Use the thumbnails selected by me”, WPP should be able to retrieve the ones you have picked and use them instead (if any).

    After this long explanation… in either case if my plugin didn’t find an image it’ll show the default picture (which can be changed, btw). You need to either specify one (if you picked “Use the thumbnails selected by me”) or attach an image to your post (“Generate all thumbnails for me”) so WPP can use them to create an image. Otherwise, it’ll display the default “No thumbnail” image.

    Now I realize that this change I made on the last update makes things a bit more complicated than I expected… I believe I may have to re-think the way my plugin retrieves the images and make the whole process a bit more user-friendly… mmm…

    * by attached image, I mean the ones you add to your posts using the “Add an image” feature on your Edit Post page.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: WordPress Popular Posts] Some (but not all) thumbnails showing’ is closed to new replies.