WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WordPress Popular Posts] Post Title Special Character Escape Codes

[Plugin: WordPress Popular Posts] Post Title Special Character Escape Codes

Viewing 9 replies - 1 through 9 (of 9 total)
  • Anyone? Please?

    Hi there,

    Another user also reported the appended “3” number and posted a possible fix here: http://wordpress.org/support/topic/plugin-wordpress-popular-posts-disable-post-count-in-title?replies=2#post-1645791

    About the HTML characters, could you please try installing WordPress Popular Posts 2.1.5 beta to check if it solves your issue?

    Well, the good news is that the problem was fixed.

    The weird news is that I’m not sure removing the widgets from the inactive widgets zone like that guy mentioned was the reason. When I installed 2.1.5 beta, the post title was not appended with the “3” until I checked the box for “Use custom HTML Markup.” It seems to only appear if that option is selected.

    BTW, since I’m using the beta copy of the next version, what happens when the plugin is no longer in beta?

    Version 2.1.5 should be released pretty soon. The beta version you just installed is quite stable, don’t think there will be many differences with the official release.

    Thanks for pointing out the HTML Markup issue. Just checked it and wasn’t able to reproduce the bug. Mind sharing a screenshot of your current WPP widget settings with the HTML Markup feature enabled so I can test it here?

    brevityness

    @brevityness

    Hi!

    About the “3” that appears in the title when using the widget, I’m actually having the same issue.

    Everything’s fine until I had a custom end tag for the title. Whatever it might be (</h3>, </span>, etc.), there will be this 3 at the end of the title, right before the closing tag.

    ‘would have love to try the beta version, but the former link provided doesn’t work anymore.

    Any hint?

    Hey!
    I’m also having this issue! At my website http://webbhjalp.se you can right now see this in the popular post widget in the sidebar:

    Webbhjälp <span class=”red-star”>♥</span> Flattr

    And of course the span parts shouldn’t be there! I hope there is a fix for this, it would be great to be able to use span tags and stuff, it really adds to the looks of a page in my opinion!

    I have the latest version of the plugin installed and the latest wordpress!

    Thanks!

    The culprit is on line 132 of the plugin file wordpress-popular-posts.php . The title is missing the htmlspecialchars_decode() function. Replace line 132 with the following:

    echo htmlspecialchars_decode($instance['markup']['title-start'], ENT_QUOTES) . htmlspecialchars_decode($instance['title'], ENT_QUOTES) . htmlspecialchars_decode($instance['markup']['title-end'], ENT_QUOTES);

    and the mysterious appended 3 will disappear.

    Anyone ever able to resolve the title spans showing up in the popular posts output title? I too am having spans show up in the sidebar like jenseo is. luminarie, I tried your suggestion but it didn’t resolve the issue.

    Anyone? Author of this plugin seems to be MIA this year based off his WP conversation history and his link/site from above being down.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: WordPress Popular Posts] Post Title Special Character Escape Codes’ is closed to new replies.