Support » Plugin: WordPress Popular Posts » [Plugin: WordPress Popular Posts] Help – Plugin Stopped Working No Code Modifications

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Hector Cabrera

    (@hcabrera)

    Hi there,

    Can you please check that your WPP database tables exist? If so, can you share your site’s URL and your current popular posts settings?

    Hi,

    I have the following, which I believe are the correct tables for this plugin: wp_popularpostsdata and wp_popularpostsdatacache. They are full of data, 102 and 1247, respectively.
    The link to the blog posts is: http://tinyurl.com/9twkknw

    Got it resolved. I believe when upgrading wordpress or this plugin, the php code no longer worked…had to redo all of the code. and resort it by views.

    I get the same message! Check it out.
    When I go to settings, 24hr has the message, 7 days only has 2 out of 10 posts, 30 days only has 6 out of 10 posts.

    I,m not sure when to find the WPP database.

    Thanks!

    Plugin Author Hector Cabrera

    (@hcabrera)

    Kosmikkreeper,

    Just checked your site and it seems you’re using the wpp_get_mostpopular() template tag. Can you please share which parameters are being used with it (if any)?

    I just copied your short code in my sidebar.php. It was working fine until recently and I haven’t added new stuff to my blog.

    I use
    <?php if (function_exists(“get_mostpopular”)) get_mostpopular(); ?>

    but I also tried
    <?php wpp_get_mostpopular(); ?>

    and I get the same message.

    As for parameters, I haven’t touched them. Thumb source: featured image, Stylesheet: enabled, Data Tools, disabled.

    <?php if (function_exists(‘wpp_get_mostpopular’)) wpp_get_mostpopular(“range=weekly&order_by=views&limit=5&stats_comments=0&cat=’28,29,30,31,32,33′”); ?>

    This is what I am using — as you can see, I am limiting it to certain categories.

    Good luck!

    Plugin Author Hector Cabrera

    (@hcabrera)

    Hi guys,

    By default, this <?php wpp_get_mostpopular(); ?> will list the most commented post in the past 24 hours. If none of your posts have been commented within that time range, it’ll display “Sorry, no data so far”. I tested the function here and it seems to be working OK.

    If it’s not the case, please let me know!

    Can I change the default to “all time”? That’s what I need since I don’t post often.

    I got you comment and yes it does show in the sidebar but I want it to show “all time” since I rarely get comments.

    Thanks!

    Plugin Author Hector Cabrera

    (@hcabrera)

    Yes, simply set range to all and that’s it! Check isserdude’s code posted above.

    Also, in your case maybe it’d be best to list posts by views count (just as isserdude did) since your site doesn’t get that much comments.

    That worked thanks!

    Is there a way to remove to comments count after the title?

    Plugin Author Hector Cabrera

    (@hcabrera)

    Yup, add stats_comments=0 to the parameter list and the comment count won’t be displayed.

    cool thx!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: WordPress Popular Posts] Help – Plugin Stopped Working No Code Modifications’ is closed to new replies.