WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WordPress Navigation List Plugin NAVT] NAVT 1.0.27 isn’t working at all

[Plugin: WordPress Navigation List Plugin NAVT] NAVT 1.0.27 isn’t working at all

  • I just installed a fresh copy of WP2.7, and NAVT 1.0.27 (the WordPress Navigation Tool plugin). I’m using Firefox 3.0.5 to configure NAVT, and it isn’t working at all. Pushing any button yields no results. Nothing moves, nothing happens. Nothing.

    I deleted NAVT 1.0.27 and replaced it with 1.0.26. The older version is working as expected (so far).

    Hmmmmm. I *love* NATV and have used it on a bunch on WordPress installations. I hope this can get worked out soon.

    thanks
    Jen Simmons

Viewing 15 replies - 1 through 15 (of 21 total)
  • If you have FireFox with the Fire Bug extension installed then you could (possibly) tell me what problems may be shown on the Fire Bug console. Its difficult to fix things when I am not experiencing them and I don’t have anything to go on except

    Nothing moves, nothing happens. Nothing.

    Here is the error message after a category is clicked under the “categories” section in the NAVT designer. Hope this helps….
    Using:
    Firefox 3.0.5
    WP 2.7
    NAVT 1.0.27

    jQuery.data(this, “ui-sortable”) is undefined
    f()()ui.sorta…LIg%3D%3D (line 1)
    each()()jquery.j…ver=1.2.1 (line 691)
    each()()jquery.j…ver=1.2.1 (line 148)
    f()()ui.sorta…LIg%3D%3D (line 1)
    (?)()()navtadmi…er=1.0.27 (line 103)
    handle()(Object type=click target=option.asset)jquery.j…ver=1.2.1 (line 1966)
    (?)()()

    If you are on the NAVT List page, please take a look at the source code (using the Browser); do you see more than 1 line between the <head> and </head> tags that include the jQuery script?

    There are a couple of possibilities:

    1. Another jQuery script is being included in the HTML page. NAVT uses an older version of jQuery and that is by design. At the time I wrote NAVT, I used the jQuery script that was available at the time. I haven’t upgraded it because the newer one is not compatible with NAVT. It matters not, because the NAVT List page belongs to NAVT and there shouldn’t be any other plugins including a newer jQuery script; but it happens… Plugin developers don’t typically check to make sure that the scripts they include are only for the pages that belong to their plugin.

    2. The NAVT javascript (navtadmin.js) isn’t loading correctly or it is corrupt. Any single javascript error will stop the plugin from functioning completely. I find that the most common reason for the problem is #1 above. You might try deactivating all other plugins to see if the problem clears itself up; then begin activating plugins one at a time to uncover the conflict.

    Although, this does not explain why an older version would work where the newer version doesn’t. Very few changes were actually made to the new version and none of them involved the java script.

    Thanks for the info!

    It was the WordPress Automatic Upgrade plugin that the NAVT plugin was conflicting with. I just disabled the Auto Upgrade plugin and NAVT started working again.

    Info from the page header…..
    <script type=’text/javascript’ src=’http://website.com/wp-content/plugins/wordpress-automatic-upgrade/js/jquery.js?ver=2.7′></script>

    Thanks for the great work on the NAVT plugin!

    Hi gbellucci,

    I’m having the same problem, but I’m not running Automatic Upgrade. You mentioned that there might be a newer version of jQuery conflicting with NAVT’s copy, but there are no additional copies being loaded. I also tried deactivating all other plugins but this did not help. I’ve regressed to 1.0.26 which worked fine, previously, but that didn’t help, either. I did a clean install of 1.0.26.

    Can you help?

    if nothing is working on the navt admin page and ur wordpress is installed in an folder like domain.com/wordpress/ the /js/navtadmin.js.php in ur plugin folder is broken. the file try to find the right path of ur wordpress install but fails.

    my temp fix for this is to replace the following lines on top of the file (/js/navtadmin.js.php):

    //if(!defined('ABSPATH')) {
    //    define('ABSPATH', $_SERVER['DOCUMENT_ROOT'] . '/');
    //}
    
    if( file_exists('../../../../wp-load.php') ) {
        require_once('../../../../wp-load.php');
    }
    // not 2.6? then include the file directly
    elseif( file_exists('../../../../wp-config.php') ) {
        require_once('../../../../wp-config.php');
    }

    after the change u have to clean ur browser cache cause it’s a generated js file which got already cached.

    I just stumbled on this problem. Clope’s solution worked for me (thank you, I was really lost :))
    Indeed, $_SERVER[‘DOCUMENT_ROOT’] returns only the base root of the site, but if WP is on a subdirectory, the plugin doesn’t know it and gets lost.

    Alternatively to clope’s temp fix, just in order to change much less lines of code, you can just change

    define('ABSPATH', $_SERVER['DOCUMENT_ROOT'] . '/');
    to
    define('ABSPATH', $_SERVER['DOCUMENT_ROOT'] . '/wordpress/');

    Or instead of ‘/wordpress/’ whatever directory WP is installed into. I just did this and it started working perfectly again.

    Thanks for the info everyone. I had similar problem with nothing working on the admin screen for NAVT in WordPress 2.7 and NAVT 1.0.27.

    These are the changes that worked for me:

    1. Deactivate WordPress Automatic Upgrade (Thanks mcb00)
    2. Nekomuukuro’s fix because WP is installed in a subdirectory

    Be sure to reload the page completely using CTRL+F5.

    And thanks jensimmons for starting this post!

    Hi. My NAVT plugin doesn’t seem to be working at all, but for a different reason: after I install it, I simply cannot find the NAVT Admin page. Isn’t it supposed to be on Settings? (WordPress 2.7)

    Anyone else having the same problem?

    I have implemented the Nekomukuro fix anyway.

    I can’t find it either, so you are not alone!

    NAVT Admin Page is under Tools in WP 2.7

    I am having this incompatibility issue crop up with the Thesis WP theme, version 1.4. Though an early version of thesis works fine.

    I did find the admin section under Tools. However the admin page isn’t working. The plugin doesn’t seem to be initializing. And at the end of the url there is a # sign if I try to create a menu (http://mysite.com/wordpress/wp-admin/tools.php?page=wordpress-navigation-list-plugin-navt/app/navt.php#)

    I had to downgrade to 2.6 for it to work.

    I did add the code fixes to the proper file, but neither one helped. I am using Firefox on a Mac.

    having the same problem.. wp 2.7.1, navt 1.0.27, win xp sp 3, firefox 3

    I dont know why but if I do click I dont get any response its like clicking air… :S havent try last version I’ll give it a shot..

    Clope’s fix worked for me and I did NOT need to do the header/sidebar hack posted on the gbellucci.us site (I used the widget and it worked fine).

    This is a cool plugin. I stumbles across it while looking for something that would allow visitors to search the subscribers’ profiles. I may use this to provide links to featured users profiles but I’d like to find a way to change the link syntax so that it points to their profile pages rather than to their posts. I’m handy w/ code hacks. Is that something I can do w/ a known hack?

    Thanks

    Actually I switched to Nekomukuro’s fix as it’s simpler.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Plugin: WordPress Navigation List Plugin NAVT] NAVT 1.0.27 isn’t working at all’ is closed to new replies.