[Plugin: WordPress MU Sitewide Tags Pages] WPMU Not posting to Global Tags Blog (7 posts)

  1. gpaille
    Posted 7 years ago #

    I have a brand new install of WPMU on a Mac OS X server (10.3.9) and WPMU seems to be running just fine.

    I installed the site wide tag plugin 0.3.1 I get the Global Tags option under Site Admin/Options.

    I click the enabled checkbox and hit Update Options - no errors, but the checkbox never stays selected.

    The Global Posts blog is created no problem http://careo.prn.bc.ca/wpmu/tags/

    But, posting from other blogs do not show up there.

    Any ideas?




  2. Joss Winn
    Posted 7 years ago #

    Exactly the same problem here but on an existing WPMU site: http://learninglab.lincoln.ac.uk/blogs/tags/

  3. gpaille
    Posted 7 years ago #

    Joss, it looks like you may have the plugin working now. Is that true? In any case, one reason I created a new instance of wpmu was so I could install the site-wide tag plugin before any new blogs were created. Still no luck for me.

  4. gpaille
    Posted 7 years ago #

    OK, got it to work after a little mucking around. Here is what I did:

      Deleted the Global Tag Blog

      Removed the sitewide-tags.php file from within the folder it came in.

      Added the sitewide-tags.php to the mu-plugins folder.

    All is good so far!

  5. kashmirha
    Posted 7 years ago #

    Well, I can not do the last, because I would like all the posts to apear in the main blog. Or can I delete my main blog and recreate it? I mean the blog without subdomain. Any idea?

  6. davemoyer
    Posted 7 years ago #

    After having the same problem myself, I figured out that it was a simple bug in the plugin causing the issue. Here's all you need to do to solve the "phantom checkbox" issue.

    Line 40 of sitewide-tags.php has an if() line in it telling the plugin to output a certain code if it's enabled. This code will make the checkbox checked! However, rather than outputting the correct code, 'checked="checked"', it was simply outputting 'checked'. Just copy and paste in a new line 40:

    <label><input name="tags_blog_enabled" type="checkbox" id="tags_blog_enabled" value="1" <?php if( get_site_option( 'tags_blog_enabled', 0 ) == 1 ) { echo 'checked="checked"'; } ?>" /> <strong><?php _e("Enabled","wpmu-sitewide-tags"); ?></strong></label><br />

    And things should work just fine. Tell your friends ;)

  7. volanStudio
    Posted 6 years ago #

    Yeah, I am running wpmu 2.8.4a and have installed Version 0.3.2 of this plugin.

    And I got nothing.

    Nothing shows in the new blog Global Posts at all. Only the default Hello World post that is put there when the plugin creates the new blog. I've tried adding posts to other blogs (including my main /blog) and nothing shows in the Global Posts Blog. Can anyone confirm that this plugin works for 2.8.4a?

Topic Closed

This topic has been closed to new replies.

About this Topic