WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WordPress MU Sitewide Tags Pages] Works with sub.domain.com?

[Plugin: WordPress MU Sitewide Tags Pages] Works with sub.domain.com?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have it working with subdomains just fine. I am not sure if it works with subdirectories though as I have never tried it or know anyone that has.

    Trent

    It works with both subdirectories and subdomains.

    I’ve just installed this. It created the ‘tags’ blog but it’s empty:
    http://learninglab.lincoln.ac.uk/blogs/tags/

    and the ‘Enabled’ checkbox on the options page is unchecked after saving it as checked.

    Any advice on resolving this is much appreciated.
    Thanks
    Joss

    Ah, OK. It only shows tags from blogs created after the plugin has been installed.

    Josswinn,

    The “phantom checkbox” problem is quite common seeing as it’s a bug in the plugin! Thankfully it was a simple one, and a 30 second fix. I’ve emailed Donncha so hopefully it’ll be fixed soon.

    After having the same problem myself, I figured out that it was a simple bug in the plugin causing the issue. Here’s all you need to do to solve the issue.

    Line 40 of sitewide-tags.php has an if() line in it telling the plugin to output a certain code if it’s enabled. This code will make the checkbox checked! However, rather than outputting the correct code, ‘checked=”checked”‘, it was simply outputting ‘checked’. Just copy and paste in a new line 40:

    <label><input name="tags_blog_enabled" type="checkbox" id="tags_blog_enabled" value="1" <?php if( get_site_option( 'tags_blog_enabled', 0 ) == 1 ) { echo 'checked="checked"'; } ?>" /> <strong><?php _e("Enabled","wpmu-sitewide-tags"); ?></strong></label><br />

    And things should work just fine. Tell your friends 😉

    Thanks Dave. The “checked” code always worked for me in Firefox but I’ve changed the plugin now if you want to download the development version to test it.

    look like is not working on WPMU 2.7.x even with changes mentioned by @davemoyer
    Still can’t get tags.mywpmu.xxx to show sitewide tags
    🙁

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: WordPress MU Sitewide Tags Pages] Works with sub.domain.com?’ is closed to new replies.