Support » Plugin: WordPress MU Sitewide Tags Pages » [Plugin: WordPress MU Sitewide Tags Pages] Having some issues with Sitewide Tags plugin

  • Resolved kfawcett


    I’ve had a couple issues that I haven’t been able to figure out.

    In the beginning I imported all posts. The thumbnails weren’t showing up so I edited the loop to include them and they appeared.

    For some reason, I can’t remember, I deleted all the posts on the main blog. I then tried to upload using a blog ID and the images didn’t show back up. I then deleted all the posts from the main blog and tried to use the option to import all blogs. It would only import one specific blog. No matter what I tried I am not able to get it to import all blogs at once and when I import one blog, with id, at a time, the images are not showing up. The only images that show up are for the one blog when I use the all blogs option.

    Is there something I can do to figure out the cause? Is there a specific table in the db to look at or clear?

    I’m also getting this error when trying to import the blogs:
    [Tue Nov 22 04:40:50 2011] [warn] mod_fcgid: stderr: PHP Fatal error: Cannot use object of type WP_Error as array in /home/mysite/public_html/wp-content/plugins/wordpress-mu-sitewide-tags/sitewide-tags.php on line 195

    They still import, but this concerns me. Any ideas?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I think I’ve narrowed down the culprit to the theme that the posts are coming from and/or the them the main/parent blog is using.

    I have one site that is running a different theme and that is the one that is pulling the images correctly. How could a theme cause this?

    Plugin Author Ron Rennick


    For the thumbnails to come through to the SWT blog, the image has to be the featured image on the post. Some themes don’t support the featured image feature.

    All the themes use the featured image.

    I’m leaning towards it being a combination of the theme and possiblly something wrong in the DB. Does SWT write anything to the database?

    My reasoning behind something in the database being incorrect is because, my theme has a few if else statements for what image to show. The last else statement shows a “no image” picture if there isn’t a thumbnail. This is what was showing up when I first installed SWT. After changing that else statement to show the_post_thumbnail the images started to show up. I had to do some adjustments to get the thumbnails sizes correct and then I deleted all the post to repopulate the main blog.

    Somewhere along the way something happened as now when I try to import all the blogs, it only imports one of them — this one happens to be a different theme than the rest and the images show up for it. The only way I can get the other child blogs to show up is to specify the blog id and import them one by one — but the images don’t show up.

    If I change the main blogs theme to another then the thumbnail images work.


    If I don’t put any images inside the post and only have a thumbnail image, then the thumbnails will show up on the main blog.

    Plugin Author Ron Rennick


    Does SWT write anything to the database?

    Yes. It inserts the post with wp_insert_post(), etc. just like the editor screen does.


    Not sure what I was supposed to get from visiting that link.

    I just restored a backup from before installing SWT and restarted. Everything seems to be OK.

    Plugin Author Ron Rennick


    Not sure what I was supposed to get from visiting that link.

    That was an explanation of how to get thumbnails to be shown in your theme. SWT does not copy the thumbnail image, just the image html. So you need to use the WP functions for showing post thumbnails.

    Maybe I didn’t explain that clearly. I had already put the thumbnail call in my loop.

    After restoring a previous database, everything now works. Maybe it was a fluke, but something must have been corrupted in the DB.

    Thanks for your help.

    Plugin Author Ron Rennick


    I had already put the thumbnail call in my loop.

    In that case, you’re quite possibly right about the DB issue. In any event you have it sorted which is what counts 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: WordPress MU Sitewide Tags Pages] Having some issues with Sitewide Tags plugin’ is closed to new replies.