Support » Plugin: WordPress MU Sitewide Tags Pages » [Plugin: WordPress MU Sitewide Tags Pages] Error message during Populate Posts

  • Hi all, I have just reinstalled the sitewide plugin, and I get an error message when I attempt to populate posts:

    “Fatal error: Cannot use object of type WP_Error as array in /public_html/wp-content/plugins/wordpress-mu-sitewide-tags/sitewide-tags.php on line 195”

    I’m not sure what other information I can provide that may be of assistance but if anything else is needed I can reply.

    Any help would be greatly appreciated.

    http://wordpress.org/extend/plugins/wordpress-mu-sitewide-tags/

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author Ron Rennick

    (@wpmuguru)

    Which version are you using?

    Sitewide tags is 0.4.1.1 and WordPress itself is the most recent version.

    Plugin Author Ron Rennick

    (@wpmuguru)

    You either have a broken subsite or your server is having an issue making a remote request to itself.

    If you go to the network upgrade screen and run the upgrade, do you get any error messages? Does it eventually get to a message that says All done! ?

    It says all done when I do that. And actually just prior to updating the plugin I deleted and recreated the subsite. I could try it again I suppose.

    Ok, so I deleted the addon and then reinstalled it and then tried to populate and I get the same error. I notice however that even after deleting it some settings must be sticking around: the plugin is remembering the alternate name for the tags subsite I chose.

    Plugin Author Ron Rennick

    (@wpmuguru)

    You are getting the error on a wp_remote_post so there isn’t much I can do in SWT to address that. Although, it’s not clear why you want to populate from a freshly created site with the hello world post.

    The SWT settings are stored in the sitemeta table. Removing the plugin does not remove those settings.

    i’m also getting this error message, though the plugin does work for me. it populates my test messages and links everything correctly on the specified site.
    i tried doing the network update tool, and i did get an error for one site. i deactivated that site and repopulated, but i still got the same error message from the plugin.
    just thought i would let you know,
    andrew

    Plugin Author Ron Rennick

    (@wpmuguru)

    Thanks, it’s not much info to go on though. I haven’t been able to reproduce the message in my dev site. There may be some web hosts where the populate won’t work.

    ah sorry. i’m using the most recent of wordpress and the plugin. my host provider is hostpapa.com, but i don’t know much about the specifics about their services.
    what other information would be helpful?

    Plugin Author Ron Rennick

    (@wpmuguru)

    Do they have any plans larger than the $7.95 / month one?

    The populate is probably not going to work in any shared hosting plan unless it’s a really small site.

    I have a problem with this plugin: I cannot find it in the updated WP admin menu. It is a site that I haven’t been working on for a long time and I needed to make some changes, but simply cannot find it. Can it just be removed manually? Will that remove the settings? Or am I just being blind?!?!?!?!

    Plugin Author Ron Rennick

    (@wpmuguru)

    If you have an old version the menu item is under tools. The more recent versions have it under network admin.

    Yes, you can delete the plugin.

    Thanks a lot for a quick response, great!

    Strangely the menu item is nowhere to be found, but if removing it manually removes all the settings, then it is pretty straightforward!

    I’m seeing the same error… And a blank page almost immediately after hitting the Populate posts button.

    I did some testing on a multi-site with three blogs. One with about 95 posts, another over 300 posts and one with only pages and hidden from search engines. The strange thing is that the tags blog does not recieve any posts when I do Populate with the All blogs checked. But when I do it blog-by-blog, the tags blog gets populated in spite of the error (and blank page) …

    Another strange thing I noticed during the many tests with different plugin settings like Include pages, Include thumbnails and Privacy settings, one time the Populate process reached the “Finished importing posts into tags blogs!” message. This happened when populating from the smaller one of the two public blogs (so not all) and with all the default plugin options except the Privacy set to public. Trying again with the same settings from the same blog (I had cleared all posts from the tags blog first) the error occurred again.

    When populating from the hidden blog (with just 6 pages and no posts) with the Include pages and Non-Public Blogs enabled, I always see the “Finished importing posts into tags blogs!” message and no error is shown in the log file.

    I should mention this is on a WP 3.1.4 install where the plugin Networks for WordPress is also active. David Dean’s plugin is used to manage several secundary networks running on the same install. Could that cause a conflict? Or is it a memory thing?

    Hope this can be figured out so let me know if you need more info or if you need me to test some more 🙂

    Plugin Author Ron Rennick

    (@wpmuguru)

    @ravanh – the other people who were having issues with it appear to be in shared accounts. So, unless you have a VPS or larger you are probably not going to be able to use the populate posts.

    You also need the latest version for the populate to work. If you have decent server power & the latest version and still have issues, turn ALL your other plugins off and try it. ALL includes removing everything from the mu-plugins folder.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: WordPress MU Sitewide Tags Pages] Error message during Populate Posts’ is closed to new replies.