WordPress MU Domain Mapping
WordPress Admin Bar disapears - Settings won't save (8 posts)

  1. Army
    Posted 3 years ago #

    I'm posting this because this thread says the issue was resolved when it hasn't been.

    I'm using wordpress 3.3 and the twenty eleven theme for testing.

    Mapping is working but saving changed settings still does not work. Example, checking the box 'remote login' will not save and remains unchecked.

    Also, when mapping is on, the wordpress admin bar at the top of the screen disappears. When I toggle mapping off, it comes back.

    I've tried multiple versions of this plugin, including the development version but these to 2 issues persist.

    Any help is appreciated. Thank you.


  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    The issue with saving the settings has been fixed in the development version: http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/download/

    Also see my post here: http://wpmututorials.com/plugins/updates-for-wordpress-3-3/

  3. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    The toolbar (was adminbar in 3.1-3.2) shows up when I'm logged in on the mapped domain. It does not show when I'm not logged in. That's default WP behavior.

  4. Army
    Posted 3 years ago #

    The issue with saving the settings has been fixed in the development version

    Ok, so I went back and followed YOUR installation instructions instead of other instructions online and that was the difference. I made sure to install into the main wp plugins folder.

    As for the toolbar, I never logged out and expected it to be there. I simply toggled mapping on/off while stilled logged into the admin area.

    So interestingly, the test site is now showing the toolbar with mapping on but the MAIN site is not.

    Question: Since all working plugins are network activated...so they're working on both the test and main site...can I rule out any plugin cause for the toolbar to disappear in the main site?

    Any ideas why it would disappear in one but not the other?

    Thank you.

  5. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    The only plugin I know that might interfere with the toolbar on the main site is BuddyPress (since it replaces it with the buddybar).

    There may be other plugins (hello bars, etc.). You could have an error. The toolbar is close to the last content output on the page so if there was an error near the end of the page you might not get the toolbar output.

    Re: being logged in - if your users are logging into the unmapped subdomain, they may not be logged into the mapped domain. In reference to my previous post, when I was

    - logged into the main site but not the mapped domain --> no toolbar on the mapped domain

    - logged into the main site and the mapped domain --> toolbar both places

    - not logged into the main site but logged into the mapped domain --> toolbar on the mapped domain but not the main site

  6. jli
    Posted 3 years ago #

    Was investigating this issue today and realized that it was related to wp_debug being set to true.

    In fact, domain mapping is throwing notice errors which seems to be breaking the toolbar display. (The notice is the one about index HTTPS undefined).

    Well, this is not handy for debugging purpose, but when I set wp_debug back to false, everything is working as it should.

    Hope this helps.


  7. jli
    Posted 3 years ago #

    Me again.

    It seems that switching wp_debug option back and forth to false and then to true again fixed it.

    Now I can see the toolbar with wp_debug true ... Mystic it is ...

  8. Army
    Posted 3 years ago #

    The key thing for me in order to get the toolbar showing, after installing the plugin correctly, was to make sure that:

    1. 'Permanent redirect' and 'User domain mapping page' were the only boxes checked under 'Domain Mapping Configuration'. and

    2. That I was logged into the mapped site I wanted to edit.

    If I logged into the parent site only (parentsite.com/wp-login.php), then the bar doesn't display.

    I must log into the mapped domain login page and then the bar will display (othersite.com/wp-login.php). But NOT logged into the sub-domain! (parent.othersite.com//wp-login.php).

    I kept logging into the sub-domain login page and the bar didn't show up because I had the wrong boxes checked under Domain Mapping Configuration.

    Hope this makes sense. I'm sure there are other configurations that will work but this is how I need it to.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress MU Domain Mapping
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic