WordPress.org

Support

Support » Plugins and Hacks » WordPress MU Domain Mapping » [Plugin: WordPress MU Domain Mapping] Remote login not working

[Plugin: WordPress MU Domain Mapping] Remote login not working

  • Not sure when it stopped, but remote login seems to not work anymore. I’m on the latest version of WP and BP and when I navigate to a subsite that is domain mapped, I’m not logged into it. In fact, even when I’m logged into the dashboard in a separate tab, I’m still not logged in on the front side of the site.

    This used to work, but I’m not sure when it stopped working, I only noticed it recently. Can this be verified and checked by someone else too? I went with this plugin (versus the competing plugin) because you guys got this feature working a long time ago. I’d like to get that functionality back, somehow, it looks like the cookie for the main domain and the mapped domain just isn’t working together.

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

Viewing 7 replies - 1 through 7 (of 7 total)
  • As an update to this, I’m specifically referring to the SSO (single sign on) function that was working with version 0.5.4.2.

    I am using it on WP 3.4.1 with BP 1.6. SSO used to work nicely, it used to load the page of the mapped domain when a user navigated to the mapped subsite, it would do a quick refresh and then the user would be logged. That quick refresh is no longer happening and the user is not getting logged in.

    I did change to your current dev version (0.5.4.3) and the problem still exists there.

    Plugin Author Ron Rennick

    @wpmuguru

    Check for a script error.

    @ron Rennick – Not sure I understand, are you talking about a possible plugin/theme conflict?

    Ron,

    I found it, your guidance was good simply because it confused me! Turns out that the domain mapping remote login will not work with CloudFlare.

    I had noticed that the remote login was only failing to work on mapped subsites that I personally and I have all my own domain names running through Cloudflare. It must be the security features of Cloudflare that are preventing the cross-domain cookies from working.

    I toyed with reducing Cloudflare’s security settings to a minimum level but that didn’t correct the problem. The only thing that fixed it was turning Cloudflare off for those particular sites.

    I’m going to mention it to the support team at Cloudflare, but is this something you guys would research too to see if it is worth understanding and fixing in a future version of this plugin?

    I should probably start a new post here, but I am seeing the same issue, and I don’t have cloud flare running on my install. Again, I don’t know when the problem started to occur, but it did work at one point.

    How would I go about searching for scripting errors? Should I see this through firebug (I’m not seeing anything there) or by enabling WP-debug (I’ll try that next). I thought I would add here as an additional voice seeing the error. I haven’t added anything other than updating WP to the latest versions.

    Seems kind of odd and difficult to check here.

    A couple of things/quick questions:
    1. Does it require any sort of JavaScript call? If yes, then Rocket Loader might be impacting this (try turning this off).
    2. Does it work off of certain IPs?
    3. Does the behavior go away if CloudFlare is paused?

    Plugin Author Ron Rennick

    @wpmuguru

    1. Does it require any sort of JavaScript call?

    Yes.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WordPress MU Domain Mapping] Remote login not working’ is closed to new replies.
Skip to toolbar