WordPress.org

Forums

WordPress MU Domain Mapping
Post previews not working since WP 3.3 upgrade (11 posts)

  1. Joss Winn
    Member
    Posted 3 years ago #

    Since the upgrade to WP 3.3, previewing a post now gives a 404 error on sites with mapped domains.

    I updated to the development version of this plugin a couple of weeks ago but it hasn't fixed this issue. Are you aware of it? I can't see if any further changes have been made to the dev version as svn seems to be down.

    http://plugins.trac.wordpress.org/log/wordpress-mu-domain-mapping/

    Thanks.

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  2. webicycoffee
    Member
    Posted 3 years ago #

    Hey,

    I've had the same issue with previewing in 3.3. I'm running the development version of the DM plugin now (0.5.4.2) which did not fix the issue. However, when I turned off Remote Login previewing seems to be working again.

    This was an acceptable band-aid in my case because most of my users only admin a single site.

    Hope this helps

  3. Joss Winn
    Member
    Posted 3 years ago #

    Thanks for this. I can see that it works as a fix, but unfortunately, I need remove login turned on. Hopefully we can have both remote login and post previews in a forthcoming update.

  4. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    Possibly you could provide a bit more detail - ex. what are your DM settings? With your settings what does the post preview link look like?

  5. Joss Winn
    Member
    Posted 3 years ago #

    In the Domain Mapping Options, I have 1-4 checked and 5 unchecked. When I preview a post, I get the 404 page for whatever theme is in use.

    If I uncheck option 1 (remote login) and try again, it previews the post OK.

    If I check 1 again, and click preview, it shows the previewed post, but it appears to be cached, because trying to preview it in another browser, produces the 404 again.

    Thanks.

  6. webicycoffee
    Member
    Posted 3 years ago #

    Hi Ron,

    I have the following checked:

    • 2. Permanent redirect
    • 3. User DM Page
    • 4. Redirect admin to original domain

    My preview link looks like this:
    http://domain.com/path/?preview=true&preview_id=8477&preview_nonce=5a7063f3f4

    I actually get a "You do not have permission to preview drafts" and not a 404, so this may be an unrelated issue.

  7. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    Most likely the issue is that the nonce is failing (since the preview link didn't have a nonce prior to 3.3).

    There may or may not be a solution for this. Prior to 3.3 there were a couple of scenarios where post previews did not work (due to security).

  8. webicycoffee
    Member
    Posted 3 years ago #

    Your diagnosis was spot on. When I remove the nonce check I can preview published pages.

    remove_action('init', '_show_post_preview' , 10);

    Pages that are in draft, however throw a 404.

    The draft preview links look like this:
    http://mapped-domain.com/?page_id=6886&preview=true

    I also tried changing the url to the version without the mapped domain and it also kicks back a 404.

    Thanks for all the work that You and Andrea do. Your efforts make the WP community one of the best.

  9. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    Try the development version.

  10. Joss Winn
    Member
    Posted 3 years ago #

    Thanks very much. That fixes the problem.

  11. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    Joss, thanks for letting me know :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress MU Domain Mapping
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic