Support » Plugin: WordPress MU Domain Mapping » [Plugin: WordPress MU Domain Mapping] Network admin settings do not save under 3.3

  • In order to be changes to the settings after upgrading to WordPress 3.3, I need to edit the database directly through PHPmyadmin. This is happening on numerous multisite installs.

    /wp-admin/network/settings.php?page=dm_admin_page

    Remote Login
    Permanent redirect (better for your blogger’s pagerank)
    User domain mapping page
    Redirect administration pages to site’s original domain (remote login disabled if this redirect is disabled)
    Disable primary domain check. Sites will not redirect to one domain name. May cause duplicate content issues.

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Ron Rennick

    (@wpmuguru)

    That’s fixed in the development version.

    Any idea when it will be released?

    Plugin Author Ron Rennick

    (@wpmuguru)

    I’m still waiting on feedback on a number of fixes that are in the dev version.

    The development version only has bug fixes for a couple issues and fixes for a few 3.3 compatibility issues.

    Hi, my settings are still not saving, even with the most recent development version.

    The Domain Mapping page words fine—I can enter my IP or CNAME and the settings stick. But when I try to add my primary domain, it does not work. Even adding with PHPmyAdmin does not allow my main domain to be “primary”, though I can add the primary domain, which cannot be done through the plugin.

    I have access to WHM and I added the A-name entry. I also changed the settings in every way imaginable. If there is any way I can contribute to testing, please let me know.

    Hi guys – thought I’d chip in.

    I’m using WP v3.3.1 and domain mapper v0.5.4.1. For me, the checkboxes appear to work as expected, but both the CNAME and IP field go back to being empty when the page is saved.

    Although I understand that these values aren’t used to do the actual domain mapping, their being empty does prevent users from mapping domains. If they go to the domain mapping page on their sites dashboard, they are presented with a message and are not able to do anything.

    “Please set the IP address or CNAME of your server in the site admin page.”

    I’d suggest that a more useful strategy would be to allow domains to be mapped, but to present a message saying the IP must be sought from the network administrator.

    Anyway, just my $0.02. Going to try directly manipulating the tables now.

    I also have the problem detailed above. When I hit save, all the check boxes become ticked. I *think* all I want to do is to disable remote logins, but I thought I’d say that I’m waiting in anticipation for the new version too.

    WordPress 3.3, fwiw.

    Plugin Author Ron Rennick

    (@wpmuguru)

    @jamil – there is only one development version.

    For all, the development version can be downloaded from this page http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/download/

    The issues you are reporting are fixed in the development version.

    @ron – I didn’t see the development version link at the bottom of the page the first time I looked. Perhaps Jamil didn’t either.

    After copying over domain_mapping.php from the development bundle to the plugin directory, everything is now working as advertised.

    Thanks for your patience Ron. And thanks to all the devs for making a really useful plugin. (Surely a candidate for core?)

    All that said, I do think the default behaviour is a little unforgiving. IMHO users should be able to create a domain mapping without dm_ipaddress or dm_cname being set.

    Plugin Author Ron Rennick

    (@wpmuguru)

    @tdwright – thanks for the update.

    Regarding your suggestion – the next released version will only have bug/compatibility fixes in it. We aren’t planning on any feature additions/changes. We will keep your suggestion in mind if/when we do start looking at feature changes.

    @ron I was using the development version. I don’t believe what I was describing is fixed even in the development version. Unless there is something odd with my server setup but I tend to think not. It is in the root directory and as I said before, I have WHM access so I made sure the DNS settings were correct. I also tried a wide variety of other settings just in case (e.g., with and without the asterisk A-name entry).

    @tdright That said, I guess I should be moving domain_mapping.php out of the plugin the ‘wp-domain mapping…” folder and into ‘plugins’? Why? It doesn’t say to do so in the documentation.

    Plugin Author Ron Rennick

    (@wpmuguru)

    @jamil – The domain mapping plugin settings were definitely not saving in WP 3.3 (or 3.3.1) and the latest released version of DM. But I have had several people confirm that the changes I made did fix the issue for them. So, if your settings are still not saving then you will have to start looking for a cause elsewhere.

    If your reference to settings meant an issue with saving your domain maps. I’m not sure what might be causing that not to save correctly. No one else has reported an issue with that. The first thing I would try is create a test site, turning all plugins in that site and try adding a domain map to a dummy domain there.

    The domain mapping plugin does not interact with cPanel, Plesk, WHM or any of the other control panels. If you are having an issue with getting a domain directed to your site, you should start a new thread because that’s completely unrelated to the issue in this thread.

    @ron, Jamil, anyone who might know. I’m having many of the probs described above using WP3.31. What’s the proper procedure for applying the dev snapshot to my install? I write php and know my way around sh, but don’t pretend to know more than a tiny bit about how WP is laid out structurally. By the way, hello to all of you and thanks Ron, etc for all your good hard work ;o) … ~DC

    Plugin Author Ron Rennick

    (@wpmuguru)

    Upload the domain_mapping.php in the dev version and overwrite the domain_mapping.php you currently have.

    @ron… gee that sounds easy enuf… will do this afternoon… Thanks! ;o)

    @ron. updating the domain_mapping.php file fixed the problem with the settings on the domain mapping page (i.e. IP would turn into domain name and the options would always reset to original) but I still cannot add any domains on the DOMAINS page. I enter them, but nothing happens and nothing goes on the list… any ideas?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: WordPress MU Domain Mapping] Network admin settings do not save under 3.3’ is closed to new replies.