WordPress.org

Forums

[Plugin: WordPress MU Domain Mapping] Network Activate causes redirect loop (4 posts)

  1. Please help. As soon as I network activate, I get a dreaded Redirect Loop error, and I have to delete the domain_mapping.php file to get it to go away.

    I am running WP 3.1.3 with multisite enabled, just two subdomain sites, both working and browsable. I have sunrise.php in place, the sunrise defined in wp-config.php, and I verified that it does create the two domain_mapping* tables in the DB, both empty. I've tried dropping both tables and reloading the plug-in fresh, no luck. I've tried removing the multisite redirect lines in .htaccess, no effect. I've tried going through the plug-in code itself, comment out lines, etc but no luck.

    I'd once love to even see the menu itself. Help!

  2. Ron Rennick
    MultiSite Guru
    Posted 4 years ago #

    it does create the two domain_mapping* tables in the DB, both empty.

    Do not edit the site and change the domain/path to the mapped domain. Put the site back to its original URL. Then use the domain mapping admin screens to map the domain to the site.

  3. I can't even get that far - as soon as I network activate the plug-in, I can't reach any Admin pages at all, I get the redirect loop errors. I can still browse both subdomain sites ok though.

  4. As an update to this thread... I was able to get it working on a fresh installation of WordPress 3.1.3 just fine, and it works beautifully with two domain names, one mapped to a subdomain of the main site.

    So, there's something not quite right about the existing installation I have with this site... I may just migrate it off this installation and move it fresh over to the new installation as a 3rd subdomain mapping.

Topic Closed

This topic has been closed to new replies.

About this Topic

  • RSS feed for this topic
  • Started 4 years ago by PressWizards.com - Rob Marlbrough
  • Latest reply from PressWizards.com - Rob Marlbrough
  • This topic is not resolved
  • WordPress version: 3.1.3