Support » Plugin: WordPress MU Domain Mapping » [Plugin: WordPress MU Domain Mapping] Mapped Domains Work, Subdomains Don't

  • Resolved drokkon


    Thank you for this important plugin. I’ve been using it for over a year to map TLDs to separate blogs in subfolder multisite configuration. Unfortunately, today I tried, for the first time, to map a subdomain to a blog, and it didn’t work.

    I usually create an A record to point my TLD to the IP address of my server, then I use cPanel to park that TLD on top of my WordPress installation. This plugin takes it from there.

    Since a subdomain is slightly different, I used a CNAME to point it to the TLD of my main WordPress installation. Then I “parked” the subdomain on top of my WordPress installation using the “subdomains” page on cPanel, instead of the “parked domains” page.

    This resulted in an cPanel error page, even though the subdomain is set up in the plugin.

    Does anyone have any ideas? Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’m going to bump this with a simplification of what is occurring:

    1. My domain registrar points all my domains to Cloudflare nameservers.
    2. Cloudflare points my domains to my hosting IP address using A records.
    3. My cPanel has all the domains set up as “parked” on the domain that is the root address of my multisite installation.
    4. Domain Mapping Plugin sorts them out.

    Unfortunately, I’ve tried to map subdomains two ways, and neither way has worked. Here’s what I’ve tried:

    1. Add a subdomain to Cloudflare with a cname record pointing to the domain that points to the IP address. Then using the “subdomains” area
    of cPanel to point it to the document root of the multisite install.

    2. I’ve also tried to treat the subdomain like any other domain by setting it up in Cloudflare to point to the IP address with an A record, then using the “parked domains” area of cPanel to park the subdomain on top of the root multisite domain.

    No matter what I try, I’m getting the cPanel/Apache “Default Web Site Page” page.

    Can anyone tell me where I’m going wrong? Thanks!

    I’m having this same issue. My Multisite installation has worked fine for a few years. Now, suddenly, my subdomains do not work and all links using the subdomain are broken. My mapped domain names work fine, though.

    I don’t know if this is a domain-mapping plugin issue or something more fundamental. All I can think of is the recent update to 3.4.2.

    I also had a Plesk panel crash a few days ago, but my dns and wildcard settings are fine, and my hosting provider claims everything should work as before.

    I would appreciate any insights. Thank you.

    Plugin Author Ron Rennick


    MultiSite Guru

    @dponcy – the original poster is mapping subdomains (not domains) to their install and the mapped subdomains do not work. Since I’m not at all familiar with the host being used I’m not able to assist with the original problem.

    In your case, contact your hosting support. Even though they indicated that your configuration has been restored, something has changed. Most likely what is missing is the wildcard subdomain setup in your hosting control panel.

    Uh, Ron, can I give you any more details that you require to help me? I’m sorry if I wasn’t sure what to provide. My domain registrar is 1&1 which points to Cloudflare CDN which points to my own VPS running cPanel and Apache. All I know for sure is that calling the subdomain takes me all the way to my VPS, but WordPress isn’t picking it up.

    Plugin Author Ron Rennick


    MultiSite Guru

    Uh, Ron, can I give you any more details that you require to help me?

    No, you need to talk to your host support.



    I run a (thankfully managed) VPS. I am my host support.

    I solved my problem, and just wanted to document it here in case someone else runs into it.

    I basically pointed my subdomain to my blog domain using a CNAME, and obviously the blog domain pointed to my IP address using an A record.

    In cPanel I tried adding the subdomain as a subdomain, which didn’t to work. I then deleted it and tried parking the subdomain on top of my blog domain, which didn’t work.

    Weeks later, I decided to remove any reference to the subdomain from the cPanel account and I parked it using the WHM (server-level) admin.

    Tada! (Don’t ask me why…)

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: WordPress MU Domain Mapping] Mapped Domains Work, Subdomains Don't’ is closed to new replies.