WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WordPress MU Domain Mapping] Mapped domain not working, just display main site

[Plugin: WordPress MU Domain Mapping] Mapped domain not working, just display main site

  • Dear all,
    I have wordpress 3.3 site with domain site1.com, it is in hostmonster as a Primary domain. I have setup network using sub-directory mode in the site, it works well.

    I create another site: site1.com/newsite , It work well.

    Then I followed all instructions to install and setup “WordPress MU Domain Mapping” plugin and mapped netsite.com to the new site: site1.com/newsite , but mapped domain does’t work. The new domain netsite.com just only display same content as the site1.com

    In fact, the new domain netsite.com ever worked, it ever could display same content as site1.com/newsite when I finished mapping first time. But after several days, I found it became to point at site1.com although I did not do anything.

    Then I try to reinstall plugin and re-setup, It doesn’t work yet.

    Please help me.

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Ron Rennick

    @wpmuguru

    MultiSite Guru

    It’s something in your hosting or DNS setup. Do you have a redirect set up for the mapped domain?

    thanks Ron Rennick,
    The mapped netsite.com is registered in namecheap.com, and has setuped an “A record” using the IP address of site1.com, and a cname www point to netsite.com.

    And also had set netsite.com as a parked domain in hostmonster.

    Plugin Author Ron Rennick

    @wpmuguru

    MultiSite Guru

    Neither of those are a redirect. Hoewever something is redirecting the domain.

    Thanks, But I check netsite.com with seoconsultants.com/tools/check-server-headers-tool/ , There is no any redirect.

    Plugin Author Ron Rennick

    @wpmuguru

    MultiSite Guru

    You are ending up sitting at a different URL than the one you typed in the address bar so regardless of whether those tools detect it, there is a redirect.

    A redirect (and only a redirect) is what causes the browser to change the URL in the address bar.

    I sure there is not any redirect.

    Are you using the WP Super Cache plugin as well? I find myself unable to use it together with Domain Mapping, as the root URLs always show the main site.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WordPress MU Domain Mapping] Mapped domain not working, just display main site’ is closed to new replies.