Support » Plugin: WordPress MU Domain Mapping » [Plugin: WordPress MU Domain Mapping] Infinite Loop Problem

  • Resolved Eric Mann


    When I’m logged out, everything works fine. When I’m logged in, I’m unable to visit the front-end of my site.

    My main page is actually located in a sub-folder of my multisite installation: I’m mapping a domain to this installation: When I’m logged in, the front-end of my site keeps bouncing back and forth between these two domains. I can still get to the admin side just fine … but not the front-end.

    If I log out, I can view the front-end of things just fine.

    I’m using the development version of the plug-in, as I was instructed to do by several conversations with the developers. Ideas?

Viewing 13 replies - 1 through 13 (of 13 total)
  • I should also note that the other sites on this network are not having this issue. They are working properly: -> ->

    There is no infinite redirect loop here. What can I check to fix the problem?

    I’ve investigated a little deeper with some additional tools. When I’m logged in, it seems that is continuously trying to redirect to something like…&k=0decf…&t=11591… which, in turn, returns a 301 error and tries to redirect back to

    Any ideas?

    Turns out it’s some kind of conflict with the WordPress SEO plug-in by Yoast. I’m contacting the author to see if we can find a fix. In the mean time, it’s good to know how to resolve the conflict (by temporarily disabling the plug-in).

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Go to Super Admin -> Sites, then Edit the site. Fill in all the value to the mapped domain.

    I bet the issue goes away. 🙂


    I’m having trouble with it on a multisite install with WordPres SEO installed too.

    @eric Mann
    Did you get to the bottom of this? I too am having issues with it redirecting in an infinite loop.

    What do you mean fill in the value to the mapped domain? Where on the edit page do you change it?


    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Where on the edit page?

    Read it. See where it has the original blog name? Change it to the mapped domain *wherever* you find it.

    Sorry Andrea, forgive me for not being as knowledgeable as yourself with multisite, however this is my first multisite install and I have read it. There are a number of urls in there; Domain, Path, Siteurl, Home, Fileupload url to name a few.

    Is the Blogname just that? the name. I’m reluctant to change it without being sure as it is on a clients live set of sites.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    All of them that are the original subdomain or subfolder. Every single one you find on that page.

    Change it to the mapped domain.

    Thank you

    Mh.. This idea doesnt work for me.

    If I login on the page which would get the loop -> no loop
    If I login on any other page -> loop on page 1

    @Andrea_r- I just stumbled upon this thread. I’ve had problems with the “looping” but always got around it by logging in through the “main” unmapped site. With fear and trepidation I edited the mapped site as you suggested above and all seems to be well. I was worried how editing this might affect W3TC, so I re-uploaded everything to CDN and the mapped site is performing fine.

    Exactly what does editing the mapped site in this way do?


    @Andrea_r- Following your suggestions to edit the mapped site caused a significant performance drop on the unmapped site! Still trying to figure this out.


    I was having an issue with a redirect multisite domain mapping causing a loop. I solved using the right case for my domain names! I explain in detail on my blog (along with a video of the fix) if you are interested: solving redirect loop issues

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: WordPress MU Domain Mapping] Infinite Loop Problem’ is closed to new replies.