Support » Plugin: WordPress MU Domain Mapping » [Plugin: WordPress MU Domain Mapping] Going to the homepage and not the sub dir blog

  • L-Creep


    I have the latest version of WP installed and have tried to set this up. Everything looked in order with regards to accessing the backend of the blogs and also looking at the sub dir blogs by visiting the URL to them directly, however….

    When I go to the URL that is supposed to be redirected I am taken to the homepage of the blog which has this plugin installed on and the URL in the navigation bar changes to the homepage of the main site.

    Does anyone have any pointers on this?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Plugin Author Donncha O Caoimh


    Added links to that post in the readme, thanks Andrea (and Otto!)

    I have the same issue, that I have followed the domain mapping and WP setup to the letter several times, and my mapped url goes to the main sites home page, not the mapped url. Tony Zeoli kindly tried to help me figure out the problem over at

    I can’t make this work and I desparately need to! I would appreciate any help.


    Anybody have any thoughts?

    No help here.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Can you outline, exactly, every single step you DID do?

    Becasue if it’s redirected, you missed something.

    Hello! I have the plugin installed and working on a fresh install of WP3.01. sunrise.php in wp-content folder and domain-mapping.php in mu-plugins folder, added define( ‘SUNRISE’, ‘on’ ); to wp-config, have domain mapping under SuperAdmin and have added a second site.

    I want site2 to have its own url,, resolve to I host at MT on a dv and have set the dns to the correct IP address. Using Plesk, I created a new site for and forwarded it to
    When I browse to it doesn’t map to the directory, instead to
    Domain mapping in the backend of site2 has Primary domain set to

    It is forwarding but not rewriting the url to the subdirectory.

    Here is the total contents of my .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    You need the Media-temple specific directions.

    Since you;re not using cpanel, you can’t “park” the domain. Use plesk to make a Server Alias, not a forwarder. that’s part of the reason.

    OK!! I want to report back here the solution I found. 🙂

    Since I host at MediaTemple and use Plesk there are issues about how Plesk handles domain names. Essentially, when you point the dns to a server that hosts multiple domains, it looks for the url record at the server.

    Plesk forwarding does not work because the url is being handled by Plesk forwarding and the target url can’t handle the url. So I do not have an entry for the url I want to forward in Plesk.

    If you use CNAME record and url to forward, then the url is being handled by the dns setting and Plesk still isn’t letting the targeted url handle that url. It just accepts the forward and resolves to the main WP site.

    If you us A record and IP address to forward, then, since there is no record in Plesk, it resolves to the url that is set as primary. Ahha!

    So the only way to make this work with Plesk is to either have a dedicated IP or set your main WP site to the Primary url.

    I hope this makes sense and helps anyone else using Plesk.


    Hi everyone:

    Now I have an issue with Plesk myself. It is not regarding my production environment, which is set up on a domain with the main domain being

    In Plesk, I have set up
    2., which resolves to, and 3., which resolves to

    Here is my issue in Plesk.

    I need to create, as well as the aforementioned sites all for “dev.”

    I will walk through the steps.

    1. In Plesk, I have created a subdomain:
    2. I installed WPMU.
    3. I set the A Record to point to the IP address
    4. This works for perfectly
    5. I tried to create a CNAME to point:
    However, since MediaTemple only offers an IP address and not a server name for Plesk (ex., I cannot set a CNAME.
    6. I create an A Record at GoDaddy and Network Solutions for the and domains pointing to the IP address.
    7. I click on Backend in WPMU for blog ID 2 and blog ID 3 and they resolve to, and not or
    8. I went into EDIT and checked the path of both sites, as well as checked the SITE URL. Even if I set the SITE URL to, it still resolves at
    9. I check the domain mapping database tables and all the wp-options tables for /, 2, and 3, and don’t see anything specifically wrong.

    The only thing I can think of, is that the DNS settings at GoDaddy still point to their domaincontrol entries, and not mediatemple.

    Even though I have an A Record for, should I change the DNS settings to point to MediaTemple?

    With the WPMU you have to choose whether to use subdomains or subfolders. You can not have both. Also, for WPMU to work with Plesk there can be only one WPMU site for each IP address. You must set the “default” domain to your WPMU domain: in Plesk by going to Server, IP Addresses and clicking on the actual number link in the Hosting column. Choose the default domain.
    This sounds like you might have to change your production environment somewhat. Another pointer is that additional IP addresses from MT are only $1 per month. If I am reading you right, this could let you use a second IP for dev.

    Hope this helps! You helped me greatly!

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Also, for WPMU to work with Plesk there can be only one WPMU site for each IP address.

    Only if you’re using wildcard subdomains. And only on some hosts.

    I too am using Media Temple, but I am on the Grid Service. I am having trouble getting the domain mapping plugin to function appropriately.

    1) I setup my primary domain and site,, setup the WPMU, and have successfully created sub domains. Test subdomain is
    2) I added and purchased several new domain names and they were added to my MT account and were assigned to my main domain grid service.
    3) I installed the Domain Mapping Plugin and entered my IP address on the network configuration and selected the options specified at I also followed this tutorial to the T several times…
    4) When I go to my site dashboard for and I assign it one of my owned domains., the site disappears and any attempt to access the site leads to a page that just says Forbidden. I can no longer even access or it’s dashboard. I actually have to go back to the network admin and delete the domain mapping before I can get back in…

    Any help here or insight would be extremely appreciated.

    Kindest Regards,


    @dasnich On MediaTemple shared hosting, I believe what you have to do is create “symlinks.”

    This involves:

    1. Adding each domain you control to the MediaTemple DNS service. You have to register all your domains in the MediaTemple so that each domain has its own DNS Zone entry.

    2. The above will create a folder for each domain on your shared account. You want to “symlink” each folder with your primary folder. Once you create the symlinks, you then delete the folders for each domain, because you no longer need them. Symlinks basically field the request from apache and send them to the primary folder.

    This will get you to where you need to be.

    Here is the article on MediaTemple with instructions on how to create the symlinks.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: WordPress MU Domain Mapping] Going to the homepage and not the sub dir blog’ is closed to new replies.