WordPress.org

Forums

WordPress MU Domain Mapping
[resolved] Error: You are not allowed to be here (4 posts)

  1. VFHwebdev
    Member
    Posted 3 years ago #

    I'm running into a problem with Domain Mapper and a plugin called "WP Easy Columns". I've done a little searching in the support forums and it looks like there are other plugins having similar issues.

    If Domain Mapping's option to "redirect administration pages to site's original domain" is not checked, then some plugins seem to generate the error "You are not allowed to be here." when attempting to use them.

    Take a look:
    http://wordpress.org/support/topic/wp-easy-columns-not-working

    http://wordpress.org/support/topic/plugin-wordpress-mu-domain-mapping-pagepost-insert-buttons-no-longer-work

    If any of the developers for the Domain Mapping plugin could take a look at this, that would be greatly appreciated.

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    If Domain Mapping's option to "redirect administration pages to site's original domain" is not checked, then some plugins seem to generate the error "You are not allowed to be here." when attempting to use them.

    That message is being generate by WP security. If your user logs into both the unmapped and mapped domain they should not see that error message. The DM plugin will not be altered to bypass WP security.

  3. VFHwebdev
    Member
    Posted 3 years ago #

    Logging into both domains seems like a cumbersome solution.

    Perhaps the problem is with the individual plugins and the solution needs to be implemented by those developers.

    But given that it's more than one plugin, I thought the DM team might want to know about it.

  4. VFHwebdev
    Member
    Posted 3 years ago #

    I found something that may also be of use to anyone else having similar problems.

    I noticed in my DM settings for this particular site, I still had the domain set to subdomain.mydomain.org when it really should have been customdomain.org

    Updating that setting resolved the error and I do not have to check the "Redirect administrative pages to the original url" option.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress MU Domain Mapping
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic