WordPress.org

Forums

WordPress MU Domain Mapping
[resolved] Domain mapping menu not present under Tools in subsites (6 posts)

  1. gaialabs
    Member
    Posted 2 years ago #

    Hello,

    I just installed the Multisite plugin from a fresh WP install.

    I followed instructions and everything went well, excepted when I can't to map a domain to a subdomain site. The Tools > Domain mapping is present in the Network dashboard, however after I created a subdomain and then entering the Dashboard of this subdomain, there is no Domain Mapping in the Tools menu.

    I read lots of entries in this forum and elsewhere but as I can't find the solution, I posted my question here.

    Thank you for your answer.
    Kind regards

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    Do you have the User domain mapping tool checked in teh settings?

  3. gaialabs
    Member
    Posted 2 years ago #

    Hello Ron,

    Yes, it is checked. I verified that already as it is mentioned in several messages in this forum.

    To test I unchecked it and checked it again, but without success. I've still no "Domain mapping" option in the Tools menu.

    For information, I'm using wordpress in french. I tested in english, but it is the same result.

  4. gaialabs
    Member
    Posted 2 years ago #

    Hello,

    Just started some debug and it seems that a function is not called, and that could be the problem.

    In the file /wp-content/plugins/wordpress-mu-domain-mapping/domain_mapping.php, the command to add the menu in the admin page is executed:

    function dm_network_pages() {
    add_submenu_page('settings.php', 'Domain Mapping', 'Domain Mapping', 'manage_options', 'dm_admin_page', 'dm_admin_page');
    add_submenu_page('settings.php', 'Domains', 'Domains', 'manage_options', 'dm_domains_admin', 'dm_domains_admin');
    }

    However, the page which should add the menu in subdomains is not executed. I guessed it should be dm_add_pages. This function is not parsed at all, so, this could explain why it does not display the menu in "tools".

    Any idea what could occure ? I will continue my debug, but that's not easy.

    Regards.

  5. gaialabs
    Member
    Posted 2 years ago #

    I found the problem.

    You have to activate the plugin within *all* *subdomains*, not only in the network admin dashboard.

    Problem solved ;)

  6. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    Instead of activating on individual sites, go into network admin and network admin.

    If a plugin is network activated it does not appear on any of the sites' plugin pages.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress MU Domain Mapping
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic