Support » Plugin: WordPress MU Domain Mapping » [Plugin: WordPress MU Domain Mapping] Does not appear to be fully installing

  • Resolved HeavyThumper

    (@heavythumper)


    I’ve just completed a fresh install of WordPress, setup subdomain multi-site, and I’m now trying to use this plugin. I’ve added it through the plug-in installer, copied sunrise.php, and network-activated.

    When looking at the Network Admin Dashboard, I do have Domain Mapping & Domains available under Settings. Changes to Domain Mapping appear to save. However, I’m not able to make any changes in the Domains section, and when viewing my site’s dashboard I see no domain option under Tools.

    I assume I’ve done something wrong – but what?

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    check and see if the DM tables were created,

    HeavyThumper

    (@heavythumper)

    Yes, I recognize two tables created.

    I can poke values directly into the tables – and it appears to work – but any changes I try to make through the WP interface don’t save.

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    Have/can you try turning on the user mapping tool and see if you can add domain maps with that screen.

    HeavyThumper

    (@heavythumper)

    I do have the setting enabled – but I don’t see anything. Where SHOULD I see that screen?

    HeavyThumper

    (@heavythumper)

    After poking values into the table, and creating a second site (instead of one site with multiple mappings) – it now appears I can use the domain mapping tool.

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    You cannot domain map the main site. That’s why it wasn’t working for you.

    I’m also having installation issues– on a fresh WPMU 3.4.1 install.

    I’m getting no error messages on the plugin install–but no options are showing under any of my subsites’ Tools > menus in order to actually manage the domains. “Domain mapping” configuration and “Domains” are options under superuser’s settings, but that’s it. Any domain I enter under superuser > Settings > Domains disappears and does not populate the db table.

    Is this a 3.4.1 issue? Supposedly there’s nothing in the latest WP update that should cause this plugin to behave differently than in 3.4.

    Just to confirm:

    –wpmu is installed in my dev domain’s root directory. I.e., I installed wpmu to http://mydevsite.com and not a subfolder of that domain (which I know won’t work for domain mapping).

    –I manually installed the plugin: uploaded sunrise.php to the wp-content folder, updated wp-config.php, and network-activated the plugin.

    –I also set the IP in the domain mapping settings and dealt with the wildcard record on the server end, not that that should affect the issues happening.

    –I updated the network.

    Anyone else having this occur?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WordPress MU Domain Mapping] Does not appear to be fully installing’ is closed to new replies.