WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WordPress MU Domain Mapping] define SUNRISE problem resurrection!

[Plugin: WordPress MU Domain Mapping] define SUNRISE problem resurrection!

  • Hi, I have downgraded the plugin to the 0.5.2 version which works perfectly. the SUNRISE define in wp-config.php had never changed and as soon as I upgraded to 0.5.3 the bad message said “please move above… SUNRISE..” It’s a pity :s

Viewing 15 replies - 1 through 15 (of 26 total)
  • The same thing happened to me after upgrading. When I go to the settings page it gives me this,

    Please edit your /var/www/wp-config.php and move the line define( ‘SUNRISE’, ‘on’ ); above the last require_once() in that file.

    Doesn’t matter where I put define( ‘SUNRISE’, ‘on’ ); , it still gives the error.

    Copy the new sunrise.php file from wp-content/plugins/wordpress-mu-domain-mapping/sunrise.php to wp-content/sunrise.php and you’ll be fine.

    Plugin Author Donncha O Caoimh

    @donncha

    Thanks ebiven for replying. I’ve updated the readme.txt to remind people to move that file over when upgrading.

    Thanks! And the “or make sure you updated sunrise.php” is a good thing 😉

    Also, despite of the explanations on the wordpress plugin page I don’t understand the options. Perhaps it’s a language problem (I’m not english)..

    For example my main blog is : http://blogs.example.com and I have a “child blog” : 2010.example.com and another : http://www.2010.com and I have checked only # Permanent redirect + # User domain mapping page. All is working perfectly. PS : nowhere in the 2 “children blogs” you (fortunately) will find a reference to the main blog.

    So I would like to understand these options:

    1 = “Remote Login” can be disabled. Useful if you’re hosting totally separate websites.
    “remote login” seems to mean that (fortunately) someone can login everywhere :p Well, I didn’t dare to check this option, what happens if I activate it? Now, users log in at the child blog.

    2 = “Permanent redirect” uses a 301 redirect rather than 302 to send visitors to your domain mapped site.
    …My installation is new, do I need to check this option? I haven’t old pages :s ? Perhaps I should check it if I delete a post?

    3 = “User domain mapping page” allows you to disable Settings->Domain Mapping that the user uses.
    …the plugin is used to mapping. This option proposes to cancel its effects? Are you rather talking about Permalinks?

    4 = Redirect administration pages to network’s original domain
    ok, it works ^^ (I didn’t checked this option, users log in at their blogs url http://www.2010.com/wp-admin/ and 2010.example.com/wp-admin/)

    5 = Disable primary domain check. Sites will not redirect to one domain name.
    I didn’t checked this option but (fortunately) sites are not redirected to the main blog! I don’t understand at all this option :s

    So, you can see that I do not understand many things! 😀 :))

    Thank you ahead for your answers!! 😉

    Copy the new sunrise.php file from wp-content/plugins/wordpress-mu-domain-mapping/sunrise.php to wp-content/sunrise.php and you’ll be fine.

    I wish this was properly explained in the instructions… and in the change log notes, as upgrading to the the latest version caused an endless loop.

    Matt

    OK, I have copied the sunrise.php file to the wp-content folder…and I am still getting the error message.

    Please edit your /home/content/b/l/o/blogamerica/html/wp-config.php and move the line define( ‘SUNRISE’, ‘on’ ); above the last require_once() in that file or make sure you updated sunrise.php.

    Any other ideas on how to fix it?

    Defo works here on WP ‘Version 3.0.1’, two dumb questions:

    1. You 100% sure the ‘define( ‘SUNRISE’, ‘on’ );’ is actually in the wp-config.php file?

    2. Download the plugin here http://downloads.wordpress.org/plugin/wordpress-mu-domain-mapping.0.5.3.zip and copy over the sunrise.php to your ./wp-content/ folder (making a back up of the old one first)

    Matt

    Well, I went and deactivated it. Re-downloaded it, re-copied sunrise.php over, and then reactivated it. It seems to be working fine now.

    Thanks for the help.

    yay 🙂

    Hi All!,
    Just have a dumb question, hope you might forgive me.

    blog1.domain.com –> maps to —> DOMAIN1.com

    when I point my brouwser to any given url from blog1.domain.com I’m supposed to be redirected (mapped) to DOMAIN1.com.
    I’m I right?
    so far so good.

    I got sunshine and everything running on my server.

    when I point my server to blog1.domain.com the url changes to DOMAIN1.com but theres no contents to show.

    Why does this happen?
    What have I done wrong?

    Thanks!

    when I point my server to blog1.domain.com the url changes to DOMAIN1.com but theres no contents to show.

    What content DOES show? A blank page? WordPress but not text? An apache success screen? All those are different possible issues, which one is yours?

    And did you do ALL the steps to map a domain?

    Hi All,
    I’m still having trouble with this. My sunrise.php is in wp-config but it contains no text; should it do?

    Thanks,

    Steve.

    there’s a sunrise.php file included with the plugin. Move it to the wp-content folder like the plugin’s readme.txt says to.

    What content DOES show? A blank page? WordPress but not text? An apache success screen? All those are different possible issues, which one is yours?

    And did you do ALL the steps to map a domain?

    All what I get is an apache index of page.

    Hi there,

    I’ve got this sorted, thanks.

    Steve.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘[Plugin: WordPress MU Domain Mapping] define SUNRISE problem resurrection!’ is closed to new replies.