WordPress MU Domain Mapping
[resolved] Cannot Comment on Mapped Domains (9 posts)

  1. Derek
    Posted 5 years ago #

    Hey everyone,

    Has anyone seen any issues when commenting on a mapped domain? We run a sub-domain install and we are able to comment on the non-mapped domains, but get a 404 error and a strange URL when commenting on mapped domains.

    Here is an example site and URL when we get the 404:

    http://hargrovechapelumc.org/%5Ehttp:/our.site.ip.address/ <- Strange URL

    We are running the latest version of WP and the mapping plugin. If there is another forum post about this topic, please let me know, as I have searched for a couple of days about the issue.

    Thanks! Any help is greatly appreciated!


  2. Seems like you filled in the IP address somewhere you weren't supposed to. ;)

  3. Derek
    Posted 5 years ago #

    Hmm, ok. I thought there was only one place it could go. On the Network Admin -> Settings -> Domain Mapping under Server IP Address, right?

    Is there another place I should look?

    I'm pretty sure commenting worked before. Also, I know it works on a separate, personal site, and I thought I had the same set up.

    Thanks for your help.

  4. There's the spot where you actually map the domain to the site.

    If you go to the SUB site and look under Tools -> Domain Mapping, there's some options there.

  5. Derek
    Posted 5 years ago #

    Ok. I checked there and things look fine for some sites and for the example above, no domains show on the users mapping page even though I mapped them through Network Admin.

    I actually turn the user domain page option off for our users and do the mapping manually.

    It also happens on every mapped domain even though some are showing as mapped and others are not.

    Any other thoughts? Thanks!

  6. Derek
    Posted 5 years ago #

    Actually, scratch that part about it not having the mapped domain on the users domain mapping page. I had the wrong site up. The rest still applies though.

  7. Derek
    Posted 5 years ago #

    How/why is the IP address being populated into the URL like that? Is that in the plugin file, or the sunrise file?

    I have no idea why this has happened for the mapped domains. It used to work fine before.

    Thanks for any help!

  8. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 5 years ago #

    Is that in the plugin file, or the sunrise file?

    Neither. There must be something in your virtual host configuration or somewhere else that is causing that. the plugin does a str_replace of your siteurl with the mapped domain.

  9. Derek
    Posted 5 years ago #

    Ah, after I read that, I decided to check the .htaccess file. We had double checked the VHOST info and all seemed to be right there, but we hadn't checked the .htaccess file.

    I found some code that I had used to try to prevent spam. After removing this code, the comments work again. (Yay!) I'm guessing the latest updates changed a few things and the code below was not updated for 3.1 or the domain mapping version 0.5.4, or it hasn't worked at all since I added the code and no one told me.

    # attempt to stop comment spam from non-referrer requests
    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !.*nccumc.net.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule (.*) ^http://%{REMOTE_ADDR}/$ [R=301,L]

    Thank you both so much for your help! Sorry for the wild goose chase.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress MU Domain Mapping
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic