Support » Plugin: WordPress Mobile Pack - Mobile Plugin for Progressive Web Apps & Hybrid Mobile Apps » [Plugin: WordPress Mobile Pack] Page defaults to mobile view for www. in Firefox

  • I like the plugin and assumed all has been working well on my site at for several weeks – but –

    Today I was checking my Google Base pages and found all the links defaulted to the mobile browser window. – I checked further and find that in Firefox I get the mobile pages rendered if I use for any pages on my site – but not if I do not use the www. – I do not get this problem on Chrome or Safari (same rendering engine I believe)

    All settings seem correct – .htaccess seems OK – do I need anything specific in .htaccess ?

    I am using twentyten as my WP theme and the latest version of WordPress – webmaster Tools tells me all is correct and no problems

    Please Help

Viewing 1 replies (of 1 total)
  • Plugin Author AndreaTrasatti


    Could you check your cookies? in the preferences, “Privacy”, click on “Show cookies” and search for your domain. I assume you will find some cookies for the “www” and some for the naked domain. Look in the “www” set and you should have a cookie called “wpmp_switcher”. See what the “Content” field says, if it says “mobile” it means that at some point in the past you followed the link to force the mobile presentation and never removed it. Try removing that one cookie and reload the page.

    If it still does not work, let me know.

    FYI, I just tried with Firefox for Mac and I see the desktop presentation.
    Also, could you let me know the User-Agent string of your browser? If you don’t know how to get it you can see it going to

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: WordPress Mobile Pack] Page defaults to mobile view for www. in Firefox’ is closed to new replies.