Support » Plugins and Hacks » [Plugin: WordPress Importer] Importer does not work

[Plugin: WordPress Importer] Importer does not work

Viewing 13 replies - 1 through 13 (of 13 total)
  • I have the exact same problem. Any updates on this?

    It is possible that your exported file is too big for your server – this limit is set by your service provider and you may have to request them to either lift the limit, permanently or temporarily, or import the file for you.

    I have the same problem, and my exported file is only 46K (a very small site). I tried changing the filename, and putting the file in different places on my PC (Win7), all to no avail. I’m using 3.3.2 on both the source and destination sites.

    I have exactly the same problem. 🙁
    Is there any solution available? I really need the importer very urgently…



    Forum Moderator

    I’ve used this plugin dozens of times without any problem. Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    – then activating and running the plugin.

    It worked for me in the past as well.
    But I tried all your proposals and I still get a blank screen like the others mentioned above.

    If I only export the pages (without articles, menus etc) it works and imports the pages. But it does not import pictures, videos.

    As I have 92 pages it really sucks if I have to implement all pictures and menus again…



    Forum Moderator

    Have you been using any image/media handling plugins on the old site? The last time I saw an issue like this with the Importer plugin, it turned out that a plugin on the old site was handling images in a totally non-standard way – leading to database issues. when the Importer tried to deal with these, it simply couldn’t.

    Nope, but thanks for the support.

    One reason might be that there are quite a lot of large pictures involved.

    I will try “search & replace” the urls in the pages export file in combination with copying the contents from one server to the other via ftp. As I am still in the process I can’t say whether this solution works…



    Forum Moderator

    there are quite a lot of large pictures involved.

    How large are we talking about here – in terms of file size?

    The total size of the uploads folder was 130 MB.

    As my workaround luckily did the job I “only” had to rebuild the menu structure afterwards. Now everything seems to work fine.

    Nevertheless thanks for trying to find a solution for me! 🙂

    (And it still would be great if in the future the plug-in could do the complete job for me and not only pages without pictures, menus, etc. …)



    Forum Moderator

    FWIW, I carried out an import late last night from a dev to a live site and it seems to have worked perfectly. If you do have a lot of large images and one of the servers is sluggish, you could be hitting timeouts. Perhaps there’s a clue in the sever error logs of the new server?

    Not that it matters, but my site had a few images at most. It’d be nice if the importer displayed an error message, or better yet, wrote out a log we can access to see what might have gone wrong. I do not have easy access to the server logs, plus, they are huge. I cannot start recommending WordPress until I can verify that sites can be cloned without too much difficulty.

    It doesn’t work for me at all. Tried the whole day and got frustrated.

    Permission is good and everything is fine in the wp-content folder and still get the same error “The export file could not be found at /var/www/vhosts/…/httpdocs/wp-content/uploads/rb.wordpress.pages_.xml_.txt. It is likely that this was caused by a permissions problem.

    I notice it amends a .txt to the file name of the .xml file and uploads to the Media folder. If I click the Media link from the left navigation, I see the .xml file converted to .txt.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: WordPress Importer] Importer does not work’ is closed to new replies.