WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WordPress Importer] Importer Busted

[Plugin: WordPress Importer] Importer Busted

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jon Cave

    @duck_

    WordPress Dev

    This works fine for me.

    Have you tried disabling other plugins first. Is there any more information you could provide? (e.g. reported errors, what the screen looks like when it “fails”)

    Here’s an example:

    Sorry, there has been an error.
    This does not appear to be a WXR file, missing/invalid WXR version number

    I get this on each import attempt on a WordPress 3.3 install. It’s not plugins, tried those and resetting the default theme and using a fresh install.

    I just upgraded both blogs to 3.3.1, same failed result. 1/3/2012 @ 840 pm CST

    Plugin Author Jon Cave

    @duck_

    WordPress Dev

    @sheatsb:

    Can you tell me if you can find the <wp:wxr_version> tag in your export file. Open the XML file in a text editor (e.g. Notepad on Windows, vim on Linux) and try to find “wxr_version”. Then paste the whole tag and its contents here, e.g.:

    <wp:wxr_version>1.1</wp:wxr_version>

    If there is no such tag could you please email me the XML file you have? My address is: wp AT joncave.co.uk

    @biggerfish:

    Could you confirm that you receive the same error message as sheatsb. Thanks.

    I’m attempting to migrate to a new domain using the importer. It doesn’t seem to be working. I’ve tried multiple export files, with variations among post, pages, or all. I get a read error just after I upload the new file.

    Below is the error message:::

    The requested URL could not be retrieved

    While trying to retrieve the URL: http://morethingsjapanese.com/wp-admin/admin.php?

    The following error was encountered:

    Read Error
    The system returned:

    (10053) WSAECONNABORTED, Software caused connection abort.
    An error condition occurred while reading data from the network. Please retry your request.

    Your cache administrator is webmaster.

    @joncave

    I’m also getting

    Sorry, there has been an error.
    This does not appear to be a WXR file, missing/invalid WXR version number

    when trying to import into an upgraded 3.3.1 wordpress install.

    I can confirm my WP XML Export contains

    <language>en</language>
    <wp:wxr_version>1.1</wp:wxr_version>

    after the language tag. I can also confirm that the uploads directory is writable by the web server.

    Will email you the XML file if that helps.

    Plugin Author Jon Cave

    @duck_

    WordPress Dev

    It seems that this is caused by a bug in WordPress core. The actual error is that the uploaded file cannot be written to your uploads directory (permissions error), but it is being incorrectly reported by the importer plugin.

    Check this core ticket for further details: http://core.trac.wordpress.org/ticket/19800

    Hi There,

    I was having the same exact issue. I was getting the error saying there was no version number, but the version number was indeed in place.

    The solution that worked for me was to change the permissions on my wp-content/uploads folder to “777”.

    Worked like a charm and didn’t need to downgrade 3.3.1

    Cheers 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: WordPress Importer] Importer Busted’ is closed to new replies.