Support » Plugin: WordPress Importer » [Plugin: WordPress Importer] Import not working

  • I have been trying for a while now to import posts from one blog to another and it is not working.
    Both blogs have the latest version and when I upload the XML file, it keeps on loading, but nothing happens, my bowser seems to be busy but even after 4 hours, the import has not happened.

    Can anyone help me? Oh and I not technical at all so don’t understand all the technical lingo.


Viewing 9 replies - 1 through 9 (of 9 total)
  • It seems that we are having the same exact issue…

    Damn it! What did you do after coming together once a wordpress system? ‘ve budgeted, and problems began to head the fuck do the job!

    I got the pages, posts, and menu items to import, but it took two passes. The first pass I had the box checked for importing attachments, and nothing got imported. The next time I unchecked the attachments box and got plenty of results. About halfway through the list of images though it ‘failed to import’, leaving me quite a bit short.

    This has been a nightmare for me, as well. I am getting it there, kicking and screaming, by breaking the import file down into smaller chunks, putting the posts in one file, the attachments in another, as well putting the tags and categories into their own files.

    One problem I had was with some post that had dates in the future; these would hang the process. For whatever reason, when I changed their dates, they went in just fine.

    For what’s it’s worth, here’s my input. I had a very small file (400k) that kept failing and timing out. I tried the following two steps, and it worked.

    1. Confirm that the permalink structure matches that of the old blog you are importing content from.

    2. If you press the “upload” button and the browser doesn’t respond after a reasonable amount of time, click it again.

    Somehow, that kick-started WordPress, and it imported the data as normal.

    I should note this was not a one-off fluke. I’ve done this about two or three times in the past, with the same success.

    skippix, I’m assuming you FTPd these broken down XMLs into a folder in “uploads”? If so, how then did you proceed with the import? I’m trying garydarling’s strategy now but I’m kind of frustrated. Also, when I opened the xml file in dreamweaver, its color coding showed me it didn’t like all the characters (like apostrophes and stuff) that are also part of PHP etc. Wondered if that stuff not being commented out or whatever could screw it up. But I’m so not about to do a fix on THAT for 250 blog posts!! garr. Also, any tips for media library transfer would be much appreciated…

    hannah, if I recall correctly I simply left the separate XML files on my local HD and then browsed for them when prompted by the import process.

    As for the XML, that is a bit tricky. Even if Dreamweaver doesn’t like the XML file, the importer should be able to handle it. I don’t recall the content being as much of an issue as the other things (dates, permalinks, size of files).

    FWIW, my situation is decidedly different that most, as my main site is for photography; my 600-ish posts have nearly 4000 pieces of media that all are treated as separate posts. In the end, I have abandoned trying to use this plugin, instead opting for simply exporting the SQL through phpMyAdmin, then using a text editor to break the larger files down, and then importing the SQL into the target WordPress’ database. As I’m hosting through bluehost, I used their file manager to move the contents from one place to another; this could just as easily be done by zipping up the upload folder and using an FTP utility to move it somewhere else and then unzipping it.

    Thanks for that! that makes sense. I had some success with unchecking the “download and import” box – seemed to get everything, though it told me a long list of stuff it things it didn’t do… I also found that this site, which I hadn’t touched in a while (uh, my mom’s… so not a “paying” client, ha!) needed more server space allocated to it, duh. A combination of that and unchecking the box seemed to work.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: WordPress Importer] Import not working’ is closed to new replies.