Support » Plugin: WordPress Importer » [Plugin: WordPress Importer] Child Categories – Weird Behavior

  • I just made a basic site on a fresh 3.0.1 install and tried to export/import it using this plugin (which is linked to within WordPress admin screen).

    Original Site Categories:
    – Child of Foo
    – – Child of Child of Foo

    I put posts in all the categories, then exported the site. The Categories page of my new site created with the file looks like this:

    However – it gets weirder!
    Child of Foo shows up, and is checked when editing a post. It does NOT show up on my general Categories page. The link to the archives for the category work just fine. So, what is wrong with this import that the child categories don’t show up on my Categories page from within the admin screen? (They DO show when listed by category widget)

    (Additionally, when I use a theme that does some other stuff with the categories, Child of Foo does not show up there.)

Viewing 7 replies - 1 through 7 (of 7 total)
  • UPDATE: I tried the development version, and this issue appears to be corrected there.
    Is there an expected release of 0.3?

    I have the same issue. Any updates?

    Same issue here. Would appreciate an update to this as well.

    I also tried to do a hard replacement of the terms/term_taxonomy and term_relationships table – but to no avail

    Try the beta/development version – it has been working pretty well for me.

    Hi, this is still a problem in WordPress 3.1, but very easy to fix. Just add a new child category to any of your top level categories, and it’ll trigger some kind of database refresh (I guess) and all of your children categories will appear. then delete the dummy category you just created and all should be fine. in my version all of the posts and totals are correct, they just weren’t showing up on the categories page itself.

    Plugin Author Jon Cave


    WordPress Dev

    kyleduncan: are you using the latest version, which is 0.3, of the WordPress importer plugin as well as 3.1?

    The problem was old caches which get refreshed when you add a new category or even just quick edit (don’t need to change anything) and save an existing category. This should happen automatically at the end of an import using the latest version of the importer.

    Ah, my importer crashed due to memory limits, so the cache wasnt getting refreshed i guess. Thanks for the explanation!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WordPress Importer] Child Categories – Weird Behavior’ is closed to new replies.