WordPress HTTPS (SSL)
[resolved] [Plugin: WordPress HTTPS] Theme causing HTTPS partially secure (3 posts)

  1. kahlan
    Posted 5 years ago #

    Mike, thanks for this awesome plugin and support. I used your Google Chrome trick to figure out what was causing my partially insecure content, and it's all in my theme. But my theme is so dynamic there are no direct references to http, half the images are created on the fly. Any chance you could take a look and help me figure out what to change to resolve the warnings?


    (That's the only URL set to be secure; everything else should be regular HTTP.)

  2. kahlan
    Posted 5 years ago #

    I just switched to the twentyten theme for a minute, and it resolved the error. So it's definitely a problem with my "garland-revisited" theme (http://wordpress.org/extend/themes/garland-revisited).

    Running WP 3.0.4 with WordPress HTTPS 1.8.5

    Internal HTTPS elements, Disable Automatic HTTPS, and Force SSL Exclusively are on. The other WordPress HTTPS settings are unchecked.

  3. Mike Ems
    Plugin Author

    Posted 5 years ago #

    Hey trailness,

    Yes, the problem seems to be in the way in which the theme uses stylesheets. Using your site as an example, I'll make some changes to the plugin that should help with some of the warnings.

    I'm working on the next version, but I'm not sure exactly how long it'll be before it's out. I hope to release it soon, though.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic