Support » Plugin: WordPress HTTPS (SSL) » [Plugin: WordPress HTTPS (SSL)] WPEC and Blank Product Admin Page

  • I’m running the following version…

    WordPress 3.2.1
    Wordpress HTTPS 2.0.2
    WP E-Commerce w/Gold Cart

    Up until recently, before I upgraded to WP HTTPS 2.0.2, everything was working fine. I used this plugin to protect my cart and checkout pages in WPEC. And then used the wp-config file for securing my WP admin pages.

    The parameter I used in wp-config was: define(‘FORCE_SSL_ADMIN’, true);

    After upgrading, I noticed that my Product admin page pulls up blank. No 404 or anything, just a blank page. Everything else works except for this. And the only way I’ve been able to get it work is by doing one of two things…

    1) Disabling WP HTTPS entirely
    2) Enabling WP HTTPS, but disabling the “force ssl admin” option in wp-config file and disabling “Force SSL Administration” in WP HTTPS itself.

    In other words, I cannot SSL protect my Admin pages when WP HTTPS is enabled. Because, if it is, I cannot view my WPEC products.

    Wondering if anyone else has seen this problem yet? Thanks in advance of any help or advice you can give. My site can be viewed at:

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Mike Ems


    Hey kscurloc,

    Is there any chance you could try running WordPress in debug mode and see if you can see that error? Otherwise, you may need to check your Apache error logs to figure out what’s going on. I tried installing WPEC on my test server and couldn’t reproduce your issue. Note that I used WPEC


    I’m having the same issue. The Dashboard URL displays a blank page after logging into the admin section. I can view the front end of the site and all other admin pages, just not the dashboard. If I disable “WordPress HTTPS” I can view the Dashboard.

    I am NOT forcing SSL on the admin. I have tried turning it off and on, but it makes no difference.

    Any help would be appreciated!

    WP : 3.2.1
    WP-HTTPS : 2.0.4
    WPSC : v3.8.6
    Gold Cart : v2.9.4

    Here is my debug info:

    Debug Info:
    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/afadmin/public_html/ on line 3382
    Notice: Undefined index: pollresult in /home/afadmin/public_html/ on line 1335
    Notice: Undefined index: pollbooth in /home/afadmin/public_html/ on line 1341
    Notice: Undefined index: HTTPS in /home/afadmin/public_html/ on line 137
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/afadmin/public_html/ in /home/afadmin/public_html/ on line 17
    Notice: Constant WPSC_TABLE_PURCHASE_LOGS already defined in /home/afadmin/public_html/ on line 116
    Notice: Constant WPSC_TABLE_CART_CONTENTS already defined in /home/afadmin/public_html/ on line 117
    Notice: Constant WPSC_TABLE_DOWNLOAD_STATUS already defined in /home/afadmin/public_html/ on line 136

    I found the problem code. It is in the WPSC admin page in “plugins/wp-e-commerce/wpsc-admin/admin.php”. On line 588, is the function, “wpsc_dashboard_news”. This is calling “” which of course is not secured with https. This call is preventing the page from loading.

    I commented out line 561, wp_add_dashboard_widget( 'wpsc_dashboard_news', __( 'Getshopped News' , 'wpsc' ), 'wpsc_dashboard_news' ); to keep it from loading.

    This allowed my admin dashboard to load again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WordPress HTTPS (SSL)] WPEC and Blank Product Admin Page’ is closed to new replies.