Support » Plugin: WordPress HTTPS (SSL) » [Plugin: WordPress HTTPS (SSL)] WordPress HTTPS v1.9.2 error / The page isn't redirecting prope

  • Resolved fabian21

    (@fabian21)



    In case it matters, I am using the monochrome theme.

    When I attempt to force SSL on 1 page, I receive an error:
    “The page isn’t redirecting properly”
    “Firefox has detected that the server is redirecting the request for this address in a way that will never complete.”

    Any ideas would be greatly appreciated. I also have this page disabled (excluded) from the theme’s menu view and plan only to directly link to it from other page(s).

    http://wordpress.org/extend/plugins/wordpress-https/

Viewing 15 replies - 1 through 15 (of 47 total)
  • Plugin Author Mike Ems

    (@mvied)

    Does the problem exist when you use the default theme?

    fabian21

    (@fabian21)

    yes it does. i just checked it using the twenty-ten theme which if I remembered correctly, is the default.

    Plugin Author Mike Ems

    (@mvied)

    Are you using a Shared or Private SSL Cert?

    fabian21

    (@fabian21)

    i’m using netsol hosting and i purchased the ssl cert so i believe it’s private.

    Plugin Author Mike Ems

    (@mvied)

    Generally that error comes from the plugin not detecting that the page is SSL, so it tries to redirect endlessly. The opposite can be true when it identifies a page as non-SSL (but it is). Also, another plugin could be causing a conflict, although that’s uncommon.

    Have you tried the 2.0 development version? http://downloads.wordpress.org/plugin/wordpress-https.2.0.zip

    fabian21

    (@fabian21)

    no but i will now….standby.

    fabian21

    (@fabian21)

    yes the dev version appears to work.

    fabian21

    (@fabian21)

    haha, i take that back. http pages now don’t work. only the ssl one.

    fabian21

    (@fabian21)

    Anything new? I’m trying to setup my shopping cart and would like to have that page served over SSL if i can….

    Plugin Author Mike Ems

    (@mvied)

    It sounds like it’s not detecting SSL properly. I’ll need to take a look at it to see what’s going on. Unfortunately I don’t have access to a computer for the weekend. I’ll be able to look at it Monday evening at the earliest.

    If you want me to take a look, I’ll need an account on the site that can edit plugins. Once I have a fix I’ll put it in the next release (which is basically ready, so I can squeeze it in).

    I’m having the same issue on my site. Any help would be greatly appreciated!

    Here are the details…

    https://edit911.com/store/checkout/

    Internal HTTPS Elements, Disable Automatic HTTPS and Force SSL Exclusively are ON

    Everything else is OFF

    Plugin Author Mike Ems

    (@mvied)

    Hey breezy421,

    Have you tried using the 2.0 development version?

    Thanks,
    Mike

    Hi Mvied

    Getting same issues with my site. Host says it’s because they handle SSL differently with it being a cloud server and pointed me at this post:

    http://forums.tsohost.co.uk/clustered-hosting-platform-windows-hosting/747-ssl-detection.html

    Plugin Author Mike Ems

    (@mvied)

    Hey davbel,

    In the 2.0 development version, I’ve already taken $_SERVER['HTTP_X_FORWARDED_PROTO'] into account. Thanks for the tip, though. 🙂

    Thanks,
    Mike

    Hi Mike

    Thanks for that – Tried the new dev version and it appears to work i.e. I can see the HTTPS pages, but now I’m guessing I’ve got some non Https elements somewhere as it’s not showing the padlock or the SSL bar in Firefox.

    https://www.lizzielane.co.uk/shop/checkout/

Viewing 15 replies - 1 through 15 (of 47 total)
  • The topic ‘[Plugin: WordPress HTTPS (SSL)] WordPress HTTPS v1.9.2 error / The page isn't redirecting prope’ is closed to new replies.