Support » Plugin: WordPress HTTPS (SSL) » [Plugin: WordPress HTTPS (SSL)] Using your plugin with

  • Hi There,

    I have a client that has a site using eStore and We are using the SIM method. We inherited this site and he was already using this method and since he has only one golfing product, we saw no reason the use a SSL cert on his site. It is also the reason to use the SIM methos as opposed to the AIM method which would cost him more money. In the reply/response settings at, I have set his thank you page. Since the transaction takes place on a secured server, theirs, when it tries to post the thank you URL, it throws an error of unsecured content. The transaction is successful but the customers are confused.

    I am trying to make an easy fix as we are busy with other clients and saw your plugin. I have installed your plugin and set it up to force SSL only on that page. I am hoping that when tries to post that page, it will “appear” as a SSL page and display it as it is without errors. Will your plugin accomplish this?

    I hope this works as it would be an easy fix and I would gladly buy you a few beers, LOL.

    Thanks and I await your reply


Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mike Ems


    Theoretically, that is what the plugin will do. Most of the time it works out of the box, but there are things it simply can’t fix. I could spend a ton of time developing methods to fix some extra things, but it’s a lot easier to have users fix them when they run into them. There is no guarantee that the plugin will fix every error, but I’ve been refining it for a couple of years now. It’s pretty good, if I’m allowed to say so. 😛

    Edit: I might have misread, but just to clarify, you have to have an SSL certificate in order for an HTTPS page to appear secure. No way around it. If the thank you page doesn’t contain any sensitive data, which I’m assuming it won’t, I see no reason to secure that page.

    Hi Mvied,

    I agree but using the SIM method with, I have to have a https:URL for that Thank you page or it causes an error. The relay/response URL settings at are just as they should be and confirmed with anet techs. I am trying everything to find a way to make a.nets server either see that page as a https page or receive the IPN data we need for eStore and SQL db but not send that relay back or something??? You can see I’m scheming,lol

    I’ll work with the configuration. I might not have things right, who knows??
    Please feel free to share any suggestions how the plugin might work or not, ideas or suggestions.

    Thanks and Cheers –

    Plugin Author Mike Ems


    Well, if they won’t allow you to redirect to a HTTPS URL, you may be able to modify your .htaccess to always redirect users to the HTTP version of your site. I’m not sure if you’ll still get an HTTPS error or not, but it’s worth a shot. Also, my plugin has a ‘Force SSL Exclusively’ option which may work as well.

    No the problem is the thank you URL is http. They want it to be a https since its being displayed on their site. When submit is clicked it calls the relay URLof my site. According to a supervisor any relay response that is http URL will experience this insecure content error. I’m not asking my client to get a SSL cert just to display a thank you page. It’s kinda weird to me. But according to what I have read about your plugin, without a SSL cert, it won’t help me, correct?


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: WordPress HTTPS (SSL)] Using your plugin with’ is closed to new replies.