WordPress HTTPS (SSL)
Redirect HTTPS to another HTTPS subdomain (3 posts)

  1. nerdland
    Posted 4 years ago #

    I just posted this as a reply in an earlier topic that seemed related, but I just noticed that the topic was marked as "resolved," so I wanted to make sure this got seen. Apologies for the double post. Here's my problem:

    I'm trying to redirect from https://foo1.example.com/bar1 to https://foo2.example.com/bar2. They're both on the same SSL certificate, if that makes a difference, and the certificate is for *.example.com.

    It's doing some weird things, though. When I use HTTP, it works like I would expect it to. Even when it's from HTTP to HTTPS. As long as I start with HTTP, I get to my end URL, no problem.

    When I use HTTPS, it takes me to https://foo1.example.com/bar2. It takes the directory from the target URL and tries to open it on the domain from the original.

    I'm currently using the Redirection plugin to do this, (http://wordpress.org/extend/plugins/redirection/) but the same behavior happens when I hard-code the redirect into my functions file, so I'm pretty sure it isn't an issue with that plugin.

    Any ideas?


  2. nerdland
    Posted 4 years ago #

    Not sure if any of this helps, but I enabled Debug Mode and I get this stuff up top:

    SSL: Yes
    Diff Host: No
    Subdomain: No
    Proxy: No
    Secure External URLs: [ ]
    Unsecure External URLs: [ ]

    I'm not sure what all of that is supposed to be saying, but I AM on a subdomain. Is that causing weirdness?

  3. nerdland
    Posted 4 years ago #

    It occurred to me that this might be causing something, too. Not sure, but I'm trying to be as thorough as possible.

    I'm on MediaTemple's GridService hosting, which, for some reasons I don't totally understand, gets along weirdly with SSL in WordPress by default. Basically, by default, accessing the site through SSL will cause an endless redirect loop.

    They have documentation on how to make it work, which I've followed. The article provides 2 methods to fix this, but I've tried both on separate installations and the behavior is the same.

    This is pretty much Greek to me, but from what I can gather, they're rewriting HTTP_HOST to SERVER_NAME. Would that cause anything like this?


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.