WordPress.org

Forums

WordPress HTTPS (SSL)
problems with an ssl subdomain and preview (2 posts)

  1. bpang
    Member
    Posted 3 years ago #

    Using WordPress 3.3.2 and 3.0.4 of the HTTPS plugin.

    Setting the ssl url to a subdomain works, however using the:
    - SSL host: https://sslblog.domain.com
    - Using Force SSL exclusively (Posts and pages without Force SSL enabled will be redirected to HTTP.)
    - Force SSL Administration - When this is checked, editing a page post will show the permalink as https://sslblog.domain.com... which is incorrect.
    - Also, when you go to preview a post, it will try and show https://blog.domain.com... which doesn't load and shows "You do not have permission to preview drafts.. Adding ssl to the url will display the preview.

    If I turn off Force SSL Administration and set the param define('FORCE_SSL_ADMIN', true); in wp-config.php, the permalink url shows correctly, but the previews still do not work.

    I am using Cloudflare on http://blog.domain.com but not on https://sslblog.domain.com.

    Just wondering if there is a workaround for getting the previews to work in this configuration (other than adding ssl manually to the preview urls)

    http://wordpress.org/extend/plugins/wordpress-https/

  2. cyphog
    Member
    Posted 2 years ago #

    I have the exact same problem using the most recent version of the plugin (3.3.6) and the only workaround seems to disable the plugin, sign into the dashboard, and then re-enable it. which is not very secure, obviously, and (to some extent) defeates the purpose of the plugin.

    Plugin also appears to be interfering with JetPack (for me, at least).

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic