WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WordPress HTTPS (SSL)] Plugin broke my Admin Area

[Resolved] [Plugin: WordPress HTTPS (SSL)] Plugin broke my Admin Area

  • Hi There,

    I have recently updated the WordPress SSL plugin from 2.0.4 to 3.0 and then i returned to my dashboard lately it took me out of the dashboard also i have tried to insert my correct login details it didn’t let me in!

    It seems like this plugin lastest version has bugs with cookies or something like that… Please fix this issue as i have several authors who are contributed on our website they would complaint the login is not working 🙁 Please help!!!

    http://wordpress.org/extend/plugins/wordpress-https/

Viewing 15 replies - 1 through 15 (of 36 total)
  • Hi,
    Same problem as above. After upgrade to 3.0.0, the webserver stopped serving pages, and the admin area was barely accessible. Downgrade to 2.0.4 was necessary.

    Yep, Downgrading to 2.0.4 helps but upgrade to 3.0 will throw you out of Dashboard 🙁 and never let you in…

    Same problem: Dashboard not accessable

    …and some other: after upgrade to 3.0 the URL for the front page use https and not http. There is no ssl force for front page – it seems to me it use only https for the front page, if I open a side with forced ssl.
    Also some Webbrowser (like IE9) shows now the “mixed content” error.

    Therefore downgrade to 2.0.4 an all errors fixed 😉

    Why use the WordPress SSL plugin Ver. 3.0 an extra setting position? I prefer the old position.

    I upgraded the plugin from the notification pop-up and it broke my site and admin area’s as described above.

    However, I’ve now got V3.0 running fine, and the fix was pretty easy for me. All I did was first deactivate the plugin and then Delete the plugin including the https plugin folder. Confirmed my site and admin area was working fine and then went to plugins and installed V3 of the plugin, and after activating it works fine.

    In my case and perhaps many others here the issue seemed to be with the upgrade from 2.0.4 up to 3.0 from the actual WP Admin section. Perhaps upgrading by downloading the zip manually and ftp the contents may have had a different result?

    Sorry Mike, I don’t have any logs to show what might have caused the issue, hopefully this will give something to work with and hope others can get v3 working with this method.

    Plugin Author Mike Ems

    @mvied

    Hey all,

    It’s possible the upgrade process isn’t working correctly. It would be great if those having issues could set up a test site and see if they can reproduce the issues. I never had any problems, or I wouldn’t have pushed up 3.0. The more feedback I get, the faster I’ll get it fixed.

    Thanks,
    Mike

    Hi Mike,

    I could do test site unfortunately my SSL is only for single domain i cannot try to use in subdomain because it redirect me to the main site… 🙁

    Plugin Author Mike Ems

    @mvied

    You could install wordpress in a subfolder with a different database. 🙂

    Alright let me try and tell you what’s going on…

    I have tried the test version seems fine… only the issue when you install the plugin it gets you out of dashboard and sometimes it will not letting user in… but it will only affect users who are upgrading from 2.0.4 to 3.0 they’ve need to uninstall the remove the plugin from the wordpress directory then manually upload it to the http://FTP...

    Other thing is… The “HTTPS” is labelled on sidebar please revert it back to the under Settings like the one on 2.0.4 because i have different types of customs post so it takes more spaces if one item added and it’s very difficult to navigator for an admin… So please revert it back thanks…

    Plugin Author Mike Ems

    @mvied

    Hey Sulaiman,

    Thanks for the feedback, I’ll look into the issue with upgrading.

    I’ll be sure to make it a setting just for you in the next version. I wanted to put it over there to make it more obvious. 🙂

    Thanks,
    Mike

    Alright, I will look forward on the next update 🙂

    My upgrade on the test environment worked with one strange problem. The steps done:

    1. Test environment is on a subdomain. On plugin page the SSL host was set to be the subdomain, Force SSL Administration was checked and everything else was unchecked or empty.
    2. On page /wp-admin/plugins.php?plugin_status=upgrade, clicked the Upgrade automatically text link to upgrade from 2.0.4 to 3.0
    3. On admin pages: no problems.
    4. On the public website, the top of every page is now a jumble of URLs:

    http://[TESTSITE]/2012/04/http://[TESTSITE]/2012/03/http://[TESTSITE]/2012/02/http://[TESTSITE]/2012/01/http://[TESTSITE]/2011/12/

    …and so forth for each month the site has been online. Instead of [TESTSITE] is the site domain. The public website is viewed over http, which makes this even more strange, since this occurred only after this plugin update. The problem in HTML:

    <link rel="pingback" href="http://[TESTSITE]/xmlrpc.php" />
    http://[TESTSITE]/2012/04/http://[TESTSITE]/2012/03/http://[TESTSITE]/2012/02/http://[TESTSITE]/2012/01/http://[TESTSITE]/2011/12/http://[TESTSITE]/2011/11/
    <!-- This site is optimized with the Yoast WordPress SEO plugin v1.1.5 - http://yoast.com/wordpress/seo/ -->

    Deactivating WordPress HTTPS removed the problem, reactivating returned it. Deleting and reinstalling the plugin through the admin screen didn’t solve the problem.

    Is simples

    I have this problem

    Sorry I speak very low english.

    backup your wp-config.php
    edit wp-config.php and put in line 2 this text:
    define('WPHTTPS_RESET', true);
    Now open the url just the url like: wordpress.com
    re-edit the file wp-config and remove the line!
    Now works fine.

    This line reset the plugin.

    Sorry my english.

    This solution works for me!

    The update broke my admin too. Yesterday I just deleted the files and reinstalled from the plugins admin panel and that fixed it. But today, I was prompted for another update, which again broke the admin. I uninstalled, then re-installed through the plugins admin and now it seems to be fine.

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘[Resolved] [Plugin: WordPress HTTPS (SSL)] Plugin broke my Admin Area’ is closed to new replies.