WordPress HTTPS (SSL)
[resolved] Plagin does not convert my site to HTTPS (7 posts)

  1. lfox
    Posted 4 years ago #

    Hi, I'm not very techy guy, but I need your help.
    I installed and activated WordPress https v.2.0 to my site, but it does not convert it to https.

    It put automatically my site url into SSL Host field in form: http://www.mysite.com
    I purchased SSL through my hosting company (bluehost.com) along with static IP.
    What else should I do to make it work?

    Thanks a lot.



  2. bh_WP_fan
    Posted 4 years ago #

    What is your site? How did you configure the plugin? Are your WordPress and Blog URLs set to use https?

  3. lfox
    Posted 4 years ago #

    I'm using WordPress as iframe page for Facebook and it was working fine, but now facebook requires SSL connection on all pages.

    With this particular website I'm testing my iframe page.
    I use my primary website for this purpose, so I installed SSL on my entire entire website. Then I installed wordpress on subdirectory of this website. Finally, I installed WordPress https plugin v2.0. I did not make any changes to my wordpress settings yet, just for SSL Host it put my primary website in form: http://www.mysite.com (the site with SSL installed).
    Earlier, I tried adding s to http for Word Press address (URL) and Site address (URL), however after I changed that it converted to https but I was not able to sign on to my admin account . I’ve redone everything again and now I don’t know hot make it work.
    In order to my iframe page works with facebook I need to get my page URL with https and copy it to facebook apps.
    Thanks, for trying to help me.

  4. bh_WP_fan
    Posted 4 years ago #

    If the site doesn't load https (not http) by default, and if FaceBook isn't linking to it with https, then it isn't going to work.

    You have to make sure that the site is loading as https://www.yoursite.com automatically before trying to add it to FaceBook. If it's still using http then it won't work. Then you have to make sure your iframe is linking to it with https too.

  5. lfox
    Posted 4 years ago #

    I just realized that my site loading both way http and https, depends how you type in browser.
    However if I try to copy that page permalink it still show http. I don’t know if it matter, but I’m going to try to connect with facebook again.

  6. Mike Ems
    Plugin Author

    Posted 4 years ago #

    Hey Leo,

    You should be able to edit the post or page and click "Force SSL" to get it to stay HTTPS. Did you do that?


  7. lfox
    Posted 4 years ago #

    It's working now!

    Thanks a lot Mike!


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic