WordPress HTTPS (SSL)
[resolved] Only not working with plugins on the home page (5 posts)

  1. Gaperville
    Posted 3 years ago #

    Ive tried ssl and non ssl and still does not work.

    I d/l this plugin w/ hopes of making my content work properly on the home page postings and the tag links.

    My content is working fine on the .htm files (permalinks) while still showing the https. Any ideas on why or how my 2 plugins are not working on the home page and the tag links?

    Im using the Custom Contact Forms and the Pro Version of MapPress.

    Is it weird that these work over ssl in the .htm postings and not everywhere else?

    I have even tried non ssl and they are still not working. I only have the login and the admin areas on the ssl by using the WP coding in the config file they suggest to use.

    define('FORCE_SSL_LOGIN', true);

    define('FORCE_SSL_ADMIN', true);

    Any suggestions on how to properly set your plugin to make this all work?

    Thank you kindly for your support, ;-)


  2. Gaperville
    Posted 3 years ago #

    WoW! I'm using the plugin test ssl and your plugin works great for making the Pro Version of MapPress secure. This was always working regardless, just thought you may want to know this.

    My contact form is all secure, but neither of these are working on the home page or tag links.

    I started over w/ by taking out the

    define('FORCE_SSL_LOGIN', true);

    define('FORCE_SSL_ADMIN', true);

    and using the .htacess rewrite rule:

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://themassagecoupon.com/$1 [R,L]

    In the General Settings, the URL base is https too.

    Its cool to know your plugin works by using the test ssl plug.

    Maybe I have a certain setting on or off? I've tried all your settings and seem to be lost.

    Thank you kindly for your awesome work!

  3. Gaperville
    Posted 3 years ago #

    Sorry for too many posts,

    FYI: The Pro Version of MapPress Widget is working fine on the home page.

  4. Mike Ems
    Plugin Author

    Posted 3 years ago #

    Hey Gaperville,

    It's not really recommended to set your entire site to HTTPS unless you need to. The encryption process slows down your site. You really only need it on your admin panel and on any page that collects personal information.


  5. Gaperville
    Posted 3 years ago #

    GOT IT!!! had to go to my custom theme and alter the code in the content.php file as follows:

    'content' => theme_get_excerpt(),
    'content' => theme_get_content(),

    in content.php. It'll display the posts on your front page the same way as it does on single posts.

    Without having to use the plugin ( I still Love You)

    My SSL works perfect across the board!! WHEW!!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic