Support » Plugin: WordPress HTTPS (SSL) » [Plugin: WordPress HTTPS (SSL)] Issues with url and preview when editing post

  • reinventia

    (@reinventia)


    First of all, big thanks and kudos for this great pluging. It let me speechless when worked out-of-the box with zero configuration detecting the following environment:

    Main site: http://mydomain.com/index.php
    Shared SSL access: https://myuser.myhostingcompany.com/mydomain/blog/index.php

    WordPress 3.3.2 and WordPress SSL 3.0.4
    NO Force SSL Exclusively, Proxy or Debug mode.
    Force SSL Administration activated

    Buuuuut…. I found some problems when editing posts:

    0. Some things doesn’t work because the “jQuery is not defined” problem. Solved adding define(‘CONCATENATE_SCRIPTS’, false ); to wp-config.php

    1. When I publish, get notified by email of the new post pointing to the SSL url (non-SSL URL works). Annoying, and probably a WordPress issue, but I report it just in case. When writing, URL under the post title is the SSL version.

    2. Preview doesn’t work: No content found in the SSL path (https://myuser.myhostingcompany.com/mydomain/blog/?p=353&preview=true reports a 404 error). The path looks good, and preview works without the plug-in.

    2b. Also, WP-Minify has issues when building the SSL path to the css stylesheet (doesn’t add the directory part – “/mydomain/blog/”). Solved disabling it 🙂

    I hope this bring the plugin a little bit closer to perfection.
    Thanks in advance.

    http://wordpress.org/extend/plugins/wordpress-https/

  • The topic ‘[Plugin: WordPress HTTPS (SSL)] Issues with url and preview when editing post’ is closed to new replies.