WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WordPress HTTPS (SSL)] Created Secure Page but Errors when I try to preview

[Plugin: WordPress HTTPS (SSL)] Created Secure Page but Errors when I try to preview

  • carlspady
    Member

    @carlspady

    I made a page and clicked the Secure Post button but when I try to preview the page I get “Safari can’t open the page.
    Safari can’t open the page “https://healingheroesministries.org/?page_id=195” because Safari can’t establish a secure connection to the server “healingheroesministries.org”.”

    I probably need some basic training. Any help you can give would be much appreciated!

    http://wordpress.org/extend/plugins/wordpress-https/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Mike Ems
    Member

    @mvied

    Have you purchased an SSL certificate and set it up for that website?

    carlspady
    Member

    @carlspady

    Yes, that is the first thing I did.

    Plugin Author Mike Ems
    Member

    @mvied

    Well, all I can really say is that it’s not set up correctly. I can’t offer much more guidance than that. Perhaps talk to your hosting provider.

    Hi,

    IMHO some option ‘secure previews’ would be nice. I have SSL tapped to subdomain and when I’m trying to preview something the page isn’t there (404).

    It might be some caching issue (I’m using reverse proxies) or issue with securing administrative pages, but it helps setting ‘Secure post’ checkbox and then viewing the preview. So I thought such option would be nice thing — an option that would force previews to be served with HTTPS.

    Regards,
    paweł

    carlspady
    Member

    @carlspady

    Thanks. I found out I had to wait 24 hours for the SSL to activate. It’s working now.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: WordPress HTTPS (SSL)] Created Secure Page but Errors when I try to preview’ is closed to new replies.