WordPress HTTPS (SSL)
[resolved] Cannot work under Password Lock page (8 posts)

  1. kimipooh
    Posted 4 years ago #

    In case of using a password locked page in my WordPress 3.3.2 with this plugin, when I enable the Secure post, anybody cannot access to the page.

    Apache does not display any error message.


  2. kimipooh
    Posted 4 years ago #

    As a result of my check, the cause is that wp-pass.php link is not changed to https.
    That wp-pass.php form action setting is included in the wp-include/temprate-post.php, but even if I change the link in the temprate-post.php, it is forcibly changed by a WordPress function (this plugin or no?). Maybe, I think that the absolute link is changed to the relative link and the temprate-post.php is applied, and then is added the siteurl.

    I hope that this plugin will cope with this issue because it is very important factor for a password-protected page using a restriction form.

  3. mrhocs
    Posted 4 years ago #

    I have the EXACT same problem and I just ran into it last night. It's really bothering me that such a crucial part to securing WP with this plugin is nonfunctional.

    If you come upon a fix can you PLEASE inform me? I will continue to try and find a fix myself and I will absolutely keep you updated if I stumble on a solution.

    Thank you

  4. kimipooh
    Posted 4 years ago #

    Hi, mrhocs.

    O. K. At least, I'd like to post here if I find out a solution or a hint.

  5. mrhocs
    Posted 4 years ago #

    Hi kimipooh,

    I have not figured out a fix yet. Have you had any luck with this problem?

    Thank you! Enjoy your week.

  6. kimipooh
    Posted 4 years ago #

    Hi, mrhocs.

    As a result of analyzing the plugin and the Wordprss (3.3.2), I could find out the avoidance approach.
    Please see the following page.
    - http://www.cseas.kyoto-u.ac.jp/info/en/faq-en/wordpress#1

    I hope that the password lock function in WordPress supports SSL.

  7. kimipooh
    Posted 4 years ago #

    WordPress 3.4 seems to support this issue.
    If you use the above custom filter, please disable it.

  8. mrhocs
    Posted 4 years ago #

    Hi kimipooh!

    I'm bummed. I never got the email notification that you responded 3 weeks ago! I wish I did see that fix you found. That's really cool.

    Thank you so much for the update! I'm going to adjust a few files and upgrade to WP 4.3.

    Thank you again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic