WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WordPress HTTPS (SSL)] Activating 3.1.1 causing Fatal Error

[Resolved] [Plugin: WordPress HTTPS (SSL)] Activating 3.1.1 causing Fatal Error

  • Every time I have tried to update after version 2.0.4, I get this:
    Plugin could not be activated because it triggered a fatal error.

    Fatal error: Class ‘WordPressHTTPS’ not found in /home/—–/public_html/wp-content/plugins/wordpress-https/wordpress-https.php on line 49

    Line 49 of this file reads: $wordpress_https = new WordPressHTTPS;

    Why am I having this problem? (and it seems – nobody else is?)

    http://wordpress.org/extend/plugins/wordpress-https/

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Mike Ems
    Member

    @mvied

    Uninstall the plugin completely and re-install. Let me know if that works.

    Thanks for your response Mike.

    Completely uninstalled 2.0.4 (including all wordpress-https options in database).
    Installed 3.1.2 and same deal – trying to activate gave:

    Fatal error: Class ‘WordPressHTTPS’ not found in /home/—–/public_html/wp-content/plugins/wordpress-https/wordpress-https.php on line 49

    Tried deleting this line, then activating and got:

    Fatal error: Call to a member function setSlug() on a non-object in /home/—–/public_html/wp-content/plugins/wordpress-https/wordpress-https.php on line 49

    My wp-config has:
    /** Force Admin login to SSL. */
    define(‘FORCE_SSL_LOGIN’, true);
    define(‘FORCE_SSL_ADMIN’, true);
    Tried setting these to false – same.

    Everything works perfectly with version 2.0.4

    Plugin Author Mike Ems
    Member

    @mvied

    It’s possible you have an old version of PHP or something? Is there any way you could check?

    Running PHP Version 5.3.13, MySQL Version 5.1.63
    Standard LAMP (Centos) but on an Xen VPS server.

    Recently had trouble with latest update of another plugin:
    GWA Autoresponder Pro – activating latest version5 gobbles all the memory.
    The plugin developer still hasn’t sorted that one.

    I have a near identical test website set up on this same server, and activating latest WP-https plugin on this site is no problem (but of course this website doesn’t have an SSL certificate installed).

    Plugin Author Mike Ems
    Member

    @mvied

    The only other thing that it could be is file permissions. Make sure that the Apache/PHP user can read all of the files.

    Thanks for your suggestions Mike,
    Setting permissions to world writable (777) for all files and folders of the plugin, including my wp-config, just returns the same error on activation.

    Looking at the error log in cpanel; every time I installed and tried to activate latest version, this error got recorded (twice):

    PHP Fatal error: Class ‘WordPressHTTPS’ not found in /home/—–/public_html/wp-content/plugins/wordpress-https/wordpress-https.php on line 49, referer: https://www.lusanbidets.com.au/wp-admin/plugins.php?error=true&plugin=wordpress-https%2Fwordpress-https.php&_error_nonce=d1380ee602

    The ‘nonce=d1380ee602’ gets changed to a different number each time.

    Plugin Author Mike Ems
    Member

    @mvied

    I’m guessing if you look in wp-content/plugins/wordpress-https/lib/ you see WordPressHTTPS.php and inside it there’s code? Just to be sure, lol.

    Yep, correct code is all in there.

    Why the heck is activation of this update stalling at line 49, but V2.0.4 works without a hitch on my server?
    Using WP 3.4.1

    Once again:

    Fatal error: Class ‘WordPressHTTPS’ not found in /home/lusan/public_html/wp-content/plugins/wordpress-https/wordpress-https.php on line 49

    Line48:if ( function_exists(‘get_bloginfo’) && ! defined(‘WP_UNINSTALL_PLUGIN’) ) {
    Line49: $wordpress_https = new WordPressHTTPS;

    Tried installing manually, and then activating – same deal.

    Plugin Author Mike Ems
    Member

    @mvied

    2.0 consisted of one file that all the code was in. In 3.0, I rewrote the whole thing to better organize the code base. Your issue is that PHP is not autoloading the other, required files for some reason. The issue is either a problem with the server configuration, or another plugin is conflicting, causing the plugin not to function.

    If you can, set up a duplicate test site with the same plugins and run some tests to see if the error occurs when only my plugin is active.

    Thanks for your time Mike, I have donated to this plugin in appreciation of your work.

    I do already have a duplicate test website set up on this same server.
    WordPress HTTPS 3.1.2 activates no problem on this test site (with all the same plugins active).
    I don’t of course have an SSL certificate set up for this site, so redirects to SSL don’t work here.

    Tried activating WordPress HTTPS 3.1.2 on my live site with all other plugins deactivated – same error.

    The error is obviously being caused by some difference in server configuration between these two websites. The ONLY difference I can see is that my live site uses a dedicated IP, whereas my test site uses the shared server IP.

    Plugin Author Mike Ems
    Member

    @mvied

    It has to be something within WordPress conflicting, then. Maybe the theme?

    Nope, not the theme – tried with Twenty-Ten – same.
    Smells like something amiss in the database, what do you think?

    Plugin Author Mike Ems
    Member

    @mvied

    Well, if I could take a look I may be able to figure it out. Otherwise, I’m not really sure. My email is mike[at]mvied[dot]com.

    Id really appreciate that Mike,
    sending access details to your email address now.

    Just to be sure, I totally re-copied my live website to my test account (including the database). Same deal; plugin update activates OK on my test website, but not my live site. These two accounts in WHM are identical – except for my live site having a dedicated ip.

    Given time I can usually figure out most problems myself, but this one has me stumped!

    Plugin Author Mike Ems
    Member

    @mvied

    I think I might have already figured this out. Give my development version a shot.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Resolved] [Plugin: WordPress HTTPS (SSL)] Activating 3.1.1 causing Fatal Error’ is closed to new replies.