WordPress.org

Support

Support » Plugins and Hacks » WordPress HTTPS (SSL) » [Plugin: WordPress HTTPS] Multisite and wildcard certs – How to Use WP-HTTPS?

[Plugin: WordPress HTTPS] Multisite and wildcard certs – How to Use WP-HTTPS?

  • I run a multisite setup with a main site (MAIN.com) and several subdomain sites (SUB1.MAIN.com, SUB2.MAIN.com, etc).
    I was told that I needed a ‘wildcard ssl certificate’ which I bought and installed on my server (it is configured for ‘*.MAIN.com’ and ‘MAIN.com’).

    I’m trying to secure certain pages on the various sites using WP-HTTPS…e.g. ‘MAIN.com/securepage1’ and ‘SUB1.MAIN.com/store/securepage2’. I have checked ‘Force SSL’ on the relevant page publish settings.

    problem: I get no ssl connection when navigating to the pages using https://
    Chrome pulls a ‘SSL connection error…error 107’ and IE8 shows a general connection error.

    So, does the plugin work with Multisites and wildcard ssl certs?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mike Ems

    @mvied

    Hey Cap’n,

    Having never seen an SSL 107 error before, my first instinct was to Google it. Everything I’m reading says that the error is caused by a browser cache issue, most commonly in Google Chrome. That’s the only information I can find on it.

    http://www.fixya.com/support/t2440256-error_107_net_err_ssl_protocol_error

    Let me know if that helps.

    Thanks,
    Mike

    Mike,
    Thanks for looking that up. I believe my issue is larger than the cache in Chrome. IE8, Safari and Firefox all give me an error on attempting a https…

    I’m attempting to isolate whether this is:
    (a) a cert upload issue with my host provider,
    (b) a server config or IP address issue
    (c) a WP multisite configuration issue or,
    (d) a WP-HTTPS plugin issue.

    Hoping this forum can tell me that ‘WP-HTTPS works with multisite and wildcard ssl certs’…then I’ll keep chasing (a),(b) and (c)!

    Any ideas?

    Plugin Author Mike Ems

    @mvied

    Well, I know it sounds silly, but I haven’t tried it with a multi-site setup. I see no immediate reason why it would not work, but I’m eager to find out. I would try this setup myself, but I can’t afford a wildcard SSL at the moment. If you’d like, I can take a look at your setup and see if I can get anywhere with it. You can email details to mike[at]mvied[dot]com.

    Thanks,
    Mike

    Mike,
    Thanks for the offer. 2 things:
    – found trouble with (a) and (b)…I have to relocate my domain to a dedicated IP for the ssl to work, so once that’s done, we’ll see if the plugin works.
    – Found wildcard certs at startssl[dot]com for total of 100. gr8 guys

    I’ll report back once we have some progress.

    Thanks

    Plugin Author Mike Ems

    @mvied

    Hey Captain,

    Yeah, due to that strange error, I figured it was a server issue.

    You definitely need a dedicated IP. 🙂

    Maybe I should write an SSL guide for my users to cover issues like this. Hmm.

    Let me know when you have an update. 🙂

    Thanks,
    Mike

    Any progress here? I’m desperately trying to find a way to secure some of the pages on one of my WP multisite (3.1) mapped domains? I’m getting nervous now…is it even possible? Thanks for any assistance.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: WordPress HTTPS] Multisite and wildcard certs – How to Use WP-HTTPS?’ is closed to new replies.
Skip to toolbar