WordPress HTTPS (SSL)
[resolved] [Plugin: WordPress HTTPS] https links redirected back to http since v1.6 (6 posts)

  1. snottmonster
    Posted 5 years ago #

    My blog has a couple of pages that I force to redirect to https via the 'Force SSL' post option.

    In v1.5.x I noticed that for all other pages that do not have the 'Force SSL' option set, including the home page, if I entered the address as https:// then the page would load over https, and of course over http if I only specified http://

    In v1.6.x and now v1.7, if I try to access any page over https that does not have the 'Force SSL' options it is always redirected back to http:// even though I do not have the 'Force SSL Exclusively' option set. (The only option set in the administration settings is the default 'Internal HTTPS Elements')

    Is this how the plugin is now supposed to work? Or is this a bug? Given the presence of the option 'Force SSL Exclusively' and previous behaviour it would appear to be a bug.

  2. Mike Ems
    Plugin Author

    Posted 5 years ago #

    No, this is not how the plugin should work. You are correct about the 'Force SSL Exclusively' option.

    I can't seem to reproduce this error, so really the only way I can figure this out is if you let me take a look at your installation and let me try a few things with the plugin. It's too hard to say what could be causing this issue without looking at it myself, but that is entirely up to you.

    If you'd like me to take a look at it, you can reach me at mike[at]mvied[dot]com.

  3. Mike Ems
    Plugin Author

    Posted 5 years ago #

    I've updated the plugin to version 1.7.5. If you could, try updating and see if you still have issues. Let me know if it works for you.


  4. snottmonster
    Posted 5 years ago #

    Thanks Mike - I upgraded to the official 1.7.5release, looks to be working just fine.

    Have marked the topic [resolved]

    thanks again

  5. Uma Sumeros
    Posted 4 years ago #


    Is there any chance that you will upgrade this plugin to work with WP up to 3.2x? I used it when I had 3.0.5 installed and it worked wonderfully. It would be very helpful if you could make it work with the latest versions.

    Thank you for your work on this plugin.

  6. Mike Ems
    Plugin Author

    Posted 4 years ago #

    Hi Uma Sumeros,

    I've updated the plugin to 1.9. Both 1.9 and the previous version (1.8.5) are compatible with 3.2. If you are having issue with the plugin, please start a support topic and I'll take a look at it.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic