WordPress HTTPS (SSL)
[Plugin: WordPress HTTPS] HTTPS, forms, Pods CMS, Google Maps API (2 posts)

  1. justo8484
    Posted 5 years ago #

    I'm having an issue with a combination of the items listed in the title of this post. If you visit https://www.howproperties.com/apply-now/, you can see the issue. This page is supposed to be encrypted because the user is submitting information. The problem lies in using the property search form at the footer. Since the current page is encrypted, if I don't have the footer search submit to an encrypted page as well, the non-secure connection dialog pops up, depending on which browser you're using. You can get around this by changing the plugin settings to force HTTPS i believe, but that disallows Google Maps on the results page. The interesting thing though, is that even if I get the error message from Google Maps, the lock icon still displays for the results page, but does not for the Apply Now page. Any insight into this issue would be greatly appreciated! Thanks!

  2. Mike Ems
    Plugin Author

    Posted 5 years ago #

    Google Maps requires a Google Maps API key to load over HTTPS. If you absolutely have to have the Google Map on your secure page, that is the only way to make it secure.

    It looks like you've fixed it by removing. I don't see any Google Map on your apply-now page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic