Support » Plugins and Hacks » [Resolved] [Plugin: WordPress HTTPS] Connection Paritally Encrypted

[Resolved] [Plugin: WordPress HTTPS] Connection Paritally Encrypted

  • I mouseover the favicon at this page https://www.fcnapoli.net/training/clinics/winter-registration and the message indicates “Connection Partially Encrypted” and goes on to explain what that means.

    I’m currently using Force SSL (if I didn’t I did not see or understand how to make the url HTTPS). I’ve attempted to use a number of the other entitlements/restrictions in combination in order to change the status of the page, but no luck. Why is it site is unable to provide full encryption?

Viewing 15 replies - 16 through 30 (of 41 total)
  • Plugin Author Mike Ems


    Ah, so you want my secrets, eh? Haha.

    My secret is Google Chrome.
    1. Open the site
    2. Open the Developer tools (Ctrl + Shift + i)
    3. Click Console along the top

    On any site that’s loading insecure content, you’ll see Warnings like this The page at https://example.com/ displayed insecure content from http://example.com/css/style/css. for every insecure element on the page.

    Ah – thanks for that.

    Have been playing with a variety of tools like wget and curl, checking logs and such, to try and get such a listing of all URLs accessed during a page load.

    Scoured Safari and Firefox and have been looking for addons, but didn’t think to try chrome

    Great tip

    Plugin Author Mike Ems


    Firefox has Firebug which is really helpful, but the last time I checked, it doesn’t show Warnings for insecure content. I actually found it in Chrome because I recently switched from Firefox to Chrome, otherwise I wouldn’t have known about it.

    Hey Mvied,

    I just happily made a $50 donation, sorry it couldn’t have been more!

    Your plugin is phenomenal. It’s THE plugin for WP-ecommerce and WP SSL in general, that’s for sure! One guy online wanted to charge me $300 bugs to get me set up with SSL, and this was AFTER I bought the certificate. Soooo, I couldn’t afford the certificate AND his help, and I had to forge ahead and try to figure it all out myself. Even after the SSL certificate was installed, I kept getting the frustrating “partially encrypted” message, and I could not figure it out after hours of trying. I tried the WP plugins Admin SSL, HTTPS for WordPress but both did nothing for me(those who are reading this, be sure not to confuse the “HTTPS for WordPress” plugin with WordPress HTTPS! You want WordPress HTTPS), Then I came upon a recent post by you in a forum where you were announcing WordPress HTTPS. Thank God.

    After installing WordPress HTTPS and studying the instructions, and then playing around for some time with what to enable/not enable in the Settings, I was able to get rid of all of the “partially encrypted” errors. A HUGE help was your post previously on this forum about how you use the Chrome > Developer Tools > Console to identify what is actually causing the error message on the page. This
    allowed a real breakthrough for me, thank you, thank you.

    Now my checkout page, and a couple of others, for my store are secure on Chrome, Safari, Firefox and IE. I could not have done it without your Worpress HTTPS and the impressive support you offer here.

    -David B.

    Plugin Author Mike Ems


    David, thanks for the kind words! The frustration of WordPress with SSL is why this plugin exists. Thank you for correctly utilizing the forums and FAQ’s to figure everything out. Most questions have been asked, so it’s nice when someone utilizes the resources here rather than just ask me to do it. If you had a rating, I would give you 5/5! 🙂

    Great plug in!! I have it working on some browsers but not IE or Safari. Works great in firefox. Can you see anything wrong?? https://arizonapain.com/contact-us/physician-referral/ use ip (it is not live) only on dev server

    sorry should be more clear. If I am on a http page the click to a web form I have force ssl it is not redirecting try here http://arizonapain.com on ip then click the button physician and staff referral

    arizonapain, I’m certainly not an expert here, but since I’ve just been through some of what you are experiencing, and successfully resolved it, I can share with you that when I view your page via the Chrome browser >Developer Tools > Console, it shows a whole bunch of stuff that is blocking the encryption. I highly recommend installing Chrome for this information. It saved me hours of guessing and frustration. I’m not able to offer more than this, really, but maybe Mvied can.

    Installing now thank you. Any suggestion will help than you!

    arizonapain, in the WordPress HTTPS settings I had to play a bit with enabling/disabling “External HTTPS Elements” and “Bypass External Check” to get those factors that Chrome was showing as blocking the encryption to disappear. And I had to remove a couple of things completely, for example the plugin for a Facebook “Like” button.

    Well everything works on firefox. The main problem I am having is in IE, Safari and Chrome it is not redirecting to https at all

    Hi. My names is Antoine my website is http://www.james217apparel.com I am also having the same issue as far as seeing that it’s Connection Paritally Encrypted but it only shows that when I’m using firefox. under IE is just says that I’m Encryted. could you please help. I’m stressing myself over here. I contacted GODADDY but they said since it’s under WORDPRESS they can’t help. I don’t know what’s going on.. this is my settings…

    [X] Internal HTTPS Elements
    [X] HTTPS Front Page

    Antoine, a look at your site via Chrome>Designer Tools>Console gives the following lines of information about what items are preventing full encryption:

    The page at https://james217apparel.com/ displayed insecure content from http://i24.photobucket.com/albums/c8/Ant2003/modwidesky-02-1.jpg.
    The page at https://james217apparel.com/ displayed insecure content from http://i24.photobucket.com/albums/c8/Ant2003/gardenfire-1.jpg.

    So, this means that you have two jpgs from EXTERNAL sources that are blocking the full encryption.


    @ macroameria it took to long doing that so I took the picks and added it under the media and save the place the url in the widget. It works perfectly now… thanks for your help!!

    glad I could help!

Viewing 15 replies - 16 through 30 (of 41 total)
  • The topic ‘[Resolved] [Plugin: WordPress HTTPS] Connection Paritally Encrypted’ is closed to new replies.