WordPress.org

Forums

WordPress HTTPS (SSL)
[resolved] [Plugin: WordPress HTTPS] bloginfo template_directory still generating http instead of https (3 posts)

  1. artcoder
    Member
    Posted 4 years ago #

    I only have "Internal HTTPS Elements" checkmarked in settings.

    When I "view source" using my browser on my "secured" home page (say https://www.example.com), I'm seeing this html code for my twitter icon with "http"...

    <img src="http://www.example.com/wp-content/themes/example/images/twitter.png">

    I thought this plugin is suppose to make it generate HTML code like the following with "https" ...

    <img src="https://www.example.com/wp-content/themes/example/images/twitter.png">

    The src attribute is generated by

    <?php bloginfo('template_directory'); ?>

    in the template.

    I want to keep my WordPress address and Site Address as "http://www.example.com" in my Genreral Settings. Because I only want to force SSL on one or two pages.

  2. Mvied
    Member
    Plugin Author

    Posted 4 years ago #

    Hey artcoder,

    That's correct. I've had an increasing amount of users reporting similar issues where the plugin isn't fixing simple things. This is generally caused by the output buffering not working correctly, which the plugin uses to change elements to HTTPS.

    I could take a look at your installation if you would like. I'm in the process of adding an output buffering test to the next release so that this problem is easily identifiable.

    Thanks,
    Mike

  3. artcoder
    Member
    Posted 4 years ago #

    Thanks for the response. I had already worked-around the problem by recoding my HTML, template, etc to eliminate the "mixed secured/unsecured items" message in Internet Explorer.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic